Unintall ATT Carrier Logo

Discussion in 'Jailbreaks and iOS Hacks' started by lionheartednyhc, Sep 25, 2009.

  1. lionheartednyhc macrumors 65816

    lionheartednyhc

    Joined:
    Jul 13, 2009
    #1
    I am trying to install the new carrier file, and in order to do so I need to remove the ATT Carrier logo. The only problem is, it is not showing up under installed packages in Cydia.

    How else can I uninstall this?
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Did you possibly use MakeItMine to put something in that space ?
     
  3. lionheartednyhc thread starter macrumors 65816

    lionheartednyhc

    Joined:
    Jul 13, 2009
    #3
    Nope, I used AT&T Carrier Logo (the one that puts the little blue globe next o ATT). But it wont show up in cydia. I tried installing it again, and then uninstalling it but nothing happened.

    Hopefully someone can help, I can't get MMS working until I do!

    Thanks
     
  4. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #4
    Why would you need to uninstall the carrier logo? It's just a couple of .png files replacing the original ones. Installing a new carrier file shouldn't affect it at all. I have a modified carrier file on mine and have "AT&T Carrier Logo" installed.

    In any case, you can uninstall it by going into Cydia, searching for "AT&T Carrier Logo," clicking "Modify," then selecting "Uninstall."

    If this does not work (and I see no reason why it should not), you could always SSH in and restore the original png files from the backup copies that AT&T Carrier Logo created. The files are located in /System/Library/Carrier Bundles/ATT_US.bundle/. You will need to delete the following files:

    Default_CARRIER_ATT.png
    Default_CARRIER_CINGULAR.png
    FSO_CARRIER_ATT.png
    FSO_CARRIER_CINGULAR.png

    And rename the following files (removing .bak at the end of each):

    Default_CARRIER_ATT.png.bak
    Default_CARRIER_CINGULAR.png.bak
    FSO_CARRIER_ATT.png.bak
    FSO_CARRIER_CINGULAR.png.bak
     
  5. adster macrumors regular

    Joined:
    Aug 7, 2008
    #5
    This is what I did and it seemed to work.

    1) I installed the new IPCC without uninstalling the Carrier Logo from Cydia. The carrier logo reverted to the original after installing the IPCC
    2) I uninstalled the logo in Cydia
    3) Reboot
    4) Re-install the logo in Cydia
    5) Reboot
    6) Works as it should.
     
  6. lionheartednyhc thread starter macrumors 65816

    lionheartednyhc

    Joined:
    Jul 13, 2009
    #6

    I didn't see any .bak files but I did delete the other stuff. Is there anything else I might have to do, though? I am still getting the error.
     
  7. STEVESKI07 macrumors 68000

    STEVESKI07

    Joined:
    Jan 6, 2009
    Location:
    Washington, DC
    #7
    Did you respring after you uninstalled? The change won't take place until you do that.
     
  8. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #8
    Why do you need to remove the logo? It should have no effect on updating the carrier file.
     
  9. HighLife420 macrumors 6502a

    Joined:
    Jul 25, 2009
    #9
    did you not back up your old files?

    When i switched the carrier logo, i just swapped out the 2 PNG files. If you want to go back to stock, just put the PNG back.

    Let me know if you need the default PNGs, i backed them up before hand.
     
  10. lionheartednyhc thread starter macrumors 65816

    lionheartednyhc

    Joined:
    Jul 13, 2009
    #10
    It is the main cause of any errors people have been getting when trying to update.
     
  11. lionheartednyhc thread starter macrumors 65816

    lionheartednyhc

    Joined:
    Jul 13, 2009
    #11
    Yeah, could you please? If possible, could I just get your entire ATT_US.bundle?
     
  12. HighLife420 macrumors 6502a

    Joined:
    Jul 25, 2009
    #12
    Check PM
     
  13. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #13
  14. HighLife420 macrumors 6502a

    Joined:
    Jul 25, 2009
    #14
    are they? wow..ok, will send PM...
     
  15. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #15
    Pretty sure any files that are on the iPhone by default are property of Apple. Just figured better to be safe.
     
  16. lionheartednyhc thread starter macrumors 65816

    lionheartednyhc

    Joined:
    Jul 13, 2009
    #16
    Still no luck. Any other ideas what could be causing this? Or does the installation of the ATT Carrier change or alter anything else other than the png.s? Perhaps there is something else I need to change back...
     
  17. STEVESKI07 macrumors 68000

    STEVESKI07

    Joined:
    Jan 6, 2009
    Location:
    Washington, DC
    #17
    I'm still in the same boat as you. Seems like nobody knows what is causing this. I tried a "Reset Network Settings" and it didn't help. I want to try a "Reset All Settings" but I'm not sure if it will mess anything up with my jailbreak. Nobody here seems to know that either. If your brave and you want to try it, let me know the outcome.
     
  18. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #18
    That's what I thought, too. But when I installed the new carrier logo I got an error until I uninstalled AT&T Carrier Logo. Reinstalled it afterward with no ill effects. Another example of Apple checking to make sure we've got a clean phone before upgrading us? *shrug*

    According to Cydia, AT&T Carrier Logo changes the following files:

    /System/Library/Carrier Bundles/ATT_US.bundle/Default_CARRIER_ATT.png
    /System/Library/Carrier Bundles/ATT_US.bundle/Default_CARRIER_CINGULAR.png
    /System/Library/Carrier Bundles/ATT_US.bundle/FSO_CARRIER_ATT.png
    /System/Library/Carrier Bundles/ATT_US.bundle/FSO_CARRIER_CINGULAR.png

    /var/mobile/Library/Carrier Bundles/ATT_US.bundle/Default_CARRIER_M-cell.png
    /var/mobile/Library/Carrier Bundles/ATT_US.bundle/Default_CARRIER_ATT.png
    /var/mobile/Library/Carrier Bundles/ATT_US.bundle/Default_CARRIER_CINGULAR.png
    /var/mobile/Library/Carrier Bundles/ATT_US.bundle/FSO_CARRIER_M-Cell.png
    /var/mobile/Library/Carrier Bundles/ATT_US.bundle/FSO_CARRIER_ATT.png
    /var/mobile/Library/Carrier Bundles/ATT_US.bundle/FSO_CARRIER_CINGULAR.png
     
  19. HighLife420 macrumors 6502a

    Joined:
    Jul 25, 2009
    #19
    i dunno if anyone asked, but did you jailbreak 3.1 via custom firmware?

    if so this is a known bug...it will show your bars but not show the carrier name.

    Just checking if not..
     
  20. lionheartednyhc thread starter macrumors 65816

    lionheartednyhc

    Joined:
    Jul 13, 2009
    #20
    No, thats not the problem. I just did purplerai1n. And my carrier logo is displaying just as it would stock. Yet Im still getting the damn error, so Im thinking either something else is causing it or there is still something from the custom logo in the iphone that needs to be removed
     
  21. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #21
    Did you check *all* of the locations I listed above? You need to roll back all of those files...
     

Share This Page