iPhone Unique Boot logo issue

Discussion in 'Jailbreaks and iOS Hacks' started by Mindstormer, Apr 17, 2013.

  1. Mindstormer macrumors newbie

    Joined:
    Apr 17, 2013
    #1
    I recently noticed a huge amount of battery drain occurring on my phone, so I disabled some add-ons through SBSettings and finally uninstalled a few of them.
    Upon respring, I found my phone hanging, so I was forced to restart.

    Upon restart, the phone hung at the apple logo for about half an hour, by which point I decided to hold volume-up to disable the jailbreak temporarily.

    This got me back to my home screen, so I proceeded to remove all of my other extensions, while reinstalling mobile substrate in case there was an issue there since I want to preserve the ability to volume-up to get back in.

    No luck, still hangs at the apple logo until I hard-restart and volume-up.

    Other things tried that have been unsuccessful in fixing the issue:
    Reset all settings in general.
    Re-applied the evasion jailbreak and re-installed mobile substrate

    Right now, I'm able to boot into the disabled-jailbreak state and access cydia, I am unable to get the phone to boot back into an enabled-jailbreak state. The challenge is that I obviously can't restore and update to 6.1.3 since that's not reversible or jailbreakable with my shsh blobs and the A5 chip.

    My only guess is that the removal of one of the extensions must have removed something necessary to boot up smoothly with the jailbreak, but this theory is discredited by the fact that disabling the jailbreak solves the boot logo hanging.

    Any ideas? I'd very much hate to have to wait for the next jailbreak.

    iPhone 5, 32gb running 6.1.2
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    Did you uninstall all your tweaks? What tweak did you last install before you noticed this problem?
     
  3. erftbll81 macrumors member

    Joined:
    Sep 20, 2012
    #3
    This happened to me yesterday. I got tired of troubleshooting it and just restored =( Hope you can fix it.
     
  4. Mindstormer thread starter macrumors newbie

    Joined:
    Apr 17, 2013
    #4
    I uninstalled everything except activator and mobile substrate. However, after re-jailbraking over the old jailbreak it removed even those, which I reinstalled before rebooting, because I don't want to disable volume-up. That would be my last resort before giving up and upgrading to 6.1.3.

    The problem began after uninstalling several tweaks which froze the phone on respring, forcing me to do a hard reboot (which, in turn, probably caused the problem).

    Here's a question: Is there any way of re-enabling the jailbreak through a respring for example, rather than through a reboot?
     
  5. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #5
    Uhm, how about try to install those tweaks you were trying to uninstall that caused the freezing?
     
  6. Mindstormer thread starter macrumors newbie

    Joined:
    Apr 17, 2013
    #6
    No luck.

    Since the disabling of mobile substrate enables the ability to reboot, even when no other extensions are installed. The issue seems to be mobile substrate itself. Is there a way of trying an older version perhaps?
     
  7. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #7
    Unless you find a .deb file to an older version of mobilesubstrate and have iFile installed. Assuming you do find it, you need to uninstall mobilesubstrate using cydia before you can install it using iFile

    I know it's risky but I guess as a last resort, you could try uninstalling mobilesubstrate and see if it'll boot up normally. If it does, then you could just reinstall mobilesubstrate and hope it'll work. At this point, you're basically having an unjailbroken iPhone so it doesn't hurt too much to try. You can also try running iCleaner? Clear those cydia caches
     
  8. Mindstormer thread starter macrumors newbie

    Joined:
    Apr 17, 2013
    #8
    Rejailbroke again, device boots up perfectly without mobilesubstrate installed, but the second I install SBSettings (and therefore, mobilesubstrate), it hangs on respring until I force reboot, at which point it hangs on the apple logo again until I volume-up. So it seems like mobilesubstrate is the problem.

    Well, I then downgraded it to a version from october last year through ifile, but it still gets stuck as long as mobilesubstrate is enabled.
     
  9. JPNFRK7 macrumors 6502

    JPNFRK7

    Joined:
    Sep 27, 2012
    Location:
    California
    #9
    Are you sure it is MobileSubstrate? I have had trouble with SBSettings in the past so I uninstalled it and never looked back. Have you tried installing something else that needs MobileSubstrate?
     
  10. Mindstormer thread starter macrumors newbie

    Joined:
    Apr 17, 2013
    #10
    I have also tried with just mobile substrate on its own as well, both the present and a past version.
     
  11. Mindstormer thread starter macrumors newbie

    Joined:
    Apr 17, 2013
    #11
    For those who may benefit from the solution, it finally dawned on me to check the MobileSubstrate dynamiclibrary directory for left-behind .dylib files that might have been corrupt. After deleting them all from Library/MobileSubstrate/DynamicLibraries through iFile, the problem was solved.

    Please keep this solution in mind for future cases as uninstalling MS or even rejailbreaking over an existing jailbreak does not necessarily delete those .dylib files as in my case. :)
     

Share This Page