Unique problem after putting Radeon9000 card into 400 G4.

Discussion in 'PowerPC Macs' started by Lucibelle, Mar 20, 2009.

  1. Lucibelle macrumors member

    Mar 12, 2009
    I took the video card from a 1G DPG4 MDD model into a Gigabit Ethernet 400 G4 with 128M RAM, and it does work, but when I tried to see it in System Profiler, (OSX.4.11) it apparently is unsuccessfully relaunching the Finder, getting stuck at no further than the desktop image. The curser still responds, but I end up having to do a hard shut down. As long as I don't start System Profiler, it seems to be working fine. Have found no other issues. System Profiler worked before switching the card.

    Aside from knowing the card came out of my old (dead) MDD, I can't find a model name on the card itself. It is supposed to be an ATI Radeon9000 Pro with either 64 or 128 vram. I researched to see if it could be put into the Gigabit Ethernet 400 G4 and it is supposedly compatible.

    I recently obtained the 400 G4 and am "harvesting" the dead MDD to upgrade the 400 G4, including a PCI U160 SCSI card and two 40G U160 SCSI hard drives. Drives were put in well before the video card. No problems there. RAM will be next, then I'm donating it to a local church. I can't guarantee that someone won't eventually start System Profiler again, so would like to solve this if possible.

    Sorry for the long explanation, and I know these are dinosaur Macs. Any thoughts?
  2. velocityg4 macrumors 601


    Dec 19, 2004
    What was wrong with the MDD? Could the card also have been damaged?

    Otherwise the card should work. As both the MDD and Gigabit have the 28+ volt lead for the ADC port.

    You can try repairing permissions. Also launch Console in the utilities folder and navigate to the system.log. Then open System Profiles and see what errors pop up in console.

Share This Page