Unique problem with FSCK -y -f and reboot.

Discussion in 'MacBook' started by DC11GTR, Jun 23, 2009.

  1. DC11GTR macrumors newbie

    Joined:
    Jun 23, 2009
    #1
    I'm trying to fix a friends MacBook and have encountered an odd problem.

    It starts up in "single-user" or "verbose" mode and when I enter the "fsck -y -f", it goes through it's routine and at the end, it reads "The voume Macintosh HD appears to be OK"

    I know you're supposed to type "reboot" afterwards, and it should restart back into OSX, but here's where my strange problem lies:

    The "o" and "i" button's are broken.

    I've tried a few other solutions and get stuck the same when either of those 2 letters needs to be typed.

    I'm sure the problem would be fixed if either of those buttons worked. I'm not able to get it to startup correctly no matter what I do.

    Is there an alternative with these buttons broken?
     
  2. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #2
    Use an external USB keyboard or a Bluetooth keyboard.....
     

Share This Page