Unknowingly removed/deleted Cydia substrate

Discussion in 'Jailbreaks and iOS Hacks' started by Drago9003, Aug 29, 2015.

  1. Drago9003 macrumors newbie

    Joined:
    Aug 28, 2015
    #1
    There were some problems with my jailbroken iPhone 6(first Cydia wouldn't open unless in safe mode and then the next day phone kept crashing upon unlock,i did try deleting the last 5 tweaks I had downloaded but nothing happened) and I had to delete Cydia substrate, now when I try reinstalling Cydia substrate the TaiG jailbreak tweak thing automatically comes into the remove part of the queue, and even if I press continue and try installing substrate alongside the TaiG remove package it shows red text when it tries doing the task of removing the TaiG tweak. But I still have ifile and icleaner for some reason. So if there's nothing else to do I was wondering if restoring to iOS 8.4 was an option with me being on it(even though I know they've stopped signing it). I've already tried what others have tried helping me to do like trying Cydia impactor, which couldn't even be downloaded due to it not allowing anything to be downloaded, I've tried rejailbreaking which did nothing and tried installing deb. Files of cydia substrate/impactor which also did nothing. Please someone help me,i really don't like being stuck in this semi jailbroken state.
     
  2. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #2
    Some question to start with:
    What iOS version do you currently run (8.4)?
    Did you spoof your iOS version (by altering a plist) before the issues start happening?
    Provide a screenshot from within Cydia showing everything that is currently installed.
    If you can't take a screenshot make a list of everything that shows up as installed incl. version-no.
    Which version of Cydia Substrate did you try to re-install?
     
  3. Drago9003 thread starter macrumors newbie

    Joined:
    Aug 28, 2015
    #3
    Yes iOS 8.4
    I do not understand what spoofing is, but what was happening was that my springboard kept crashing without me installing a tweak in a while, just out of the blue so that surprised me.
    Here are all the tweaks downloaded to my phone currently http://m.imgur.com/fiOvqD9,TAWloVi,FDaMqrr
    And I only have Cydia impactor and substrate cause as I stated before I tried installation via deb files but when I did the installer it always ended up in code 256 which I think means that it didn't work.
    And so keeping that in mind the substrate version I have that was installed via deb is 0.9.5101
    Hope this info helps, thanks for the response.
     
  4. Drago9003 thread starter macrumors newbie

    Joined:
    Aug 28, 2015
    #4
    Oh and as you can see in the screenshots the TaiG tool is automatically removing itself.
     
  5. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #5
    Unfortunately your information is a little confusing.

    Initially you said you removed Cydia Substrate and were not able to re-install afterwards. But from your screenshots Cydia Substrate is installed. Also the version you mentioned is the latest one available. So there should be no need to re-install it.

    Basically, from what is shown as installed in your screenshots, your relevant Cydia packages are be complete.

    The only way Cydia will ask to remove the TaiG untether is when you have manually spoofed (means changed or modified respectively) your iOS version by altering a plist. Did you recently change your iOS version to 8.1.2 (or anything below)? Maybe for trying to install a tweak not yet updated to 8.4? I wouldn't know any other reason than a modified (=incorrect) iOS version for Cydia to try to remove the TaiG untether.
    If you have modified your iOS version reverting it back to 8.4 should fix your problem with the TaiG untether.

    The error code 256 from manually installing tweaks may appear for 2 reason. Either Cydia is still open and running while using the installer in iFile or a missing dependency (which might be the case for you since it also tries to remove the untether). In any case make sure Cydia is closed from the AppSwitcher prior to run the installer in iFile.

    Regarding the random resprings from your springboard most likely this is (was) not caused by a fault within Cydia. Remove the shady (pirate) repos as well as any tweak installed from these.
    In particular BYA and HYI repos are known to cause issues. Also AppCake might cause problems on your device.
     
  6. Drago9003 thread starter macrumors newbie

    Joined:
    Aug 28, 2015
    #6
    Hey thanks for the help, ill try the tips you said and tell you, in regards to the Cydia impactor and substrate you saw in the photos those were installed via ifile and as I said earlier it didn't work that's why I said that I pretty much don't have them.
     
  7. Drago9003 thread starter macrumors newbie

    Joined:
    Aug 28, 2015
    #7
    Hey, so, I tried removing Cydia from my multitasking and using ifile but still error code 256. Please help and tell me how to spoof or something. Here is a step by step photo wise version of me removing app cake.
    http://m.imgur.com/IurEaL9,T8LYj4z,FY1HrB2,7duBvRV,scKhnYh,Ryw9a7H
     
  8. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #8
    There's a file called SystemVersion.plist in which the actual iOS version is stored. If you didn't modify any system files or settings plists it won't help to lead you how to do it. If you have modified any system file may let me know what modification you did to which file(s).
     
  9. Drago9003 thread starter macrumors newbie

    Joined:
    Aug 28, 2015
    #9
    Oh my god,i did, I saw online on how you could change the iOS in about to fake out friends, that could be it, how do I revert it, wowco think this may work, thanks man!!!!
     
  10. Drago9003 thread starter macrumors newbie

    Joined:
    Aug 28, 2015
    #10
    I think I fixed it, in the image the 8.4 used to be a 9, tell me if everything else is correct, thanks!
     
  11. Drago9003 thread starter macrumors newbie

    Joined:
    Aug 28, 2015
    #11
    Sorry, forgot to add the photo
    http://m.imgur.com/1WJEOAO
     
  12. Drago9003 thread starter macrumors newbie

    Joined:
    Aug 28, 2015
    #12
    Thank you, so much, it worked,i could download everything/anything I want, so really sincerely thanks bro!
     
  13. HenryLong macrumors 6502

    HenryLong

    Joined:
    Apr 11, 2013
    Location:
    Germany
    #13
    Well done. Glad to see you happy again :)
     

Share This Page