Unknown error when restoring iPhone 3G to 3.0

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cmoazz, Jun 23, 2010.

  1. cmoazz macrumors newbie

    Joined:
    Jul 22, 2009
    #1
    Hey everyone...

    So I had an iPhone 3G that was running 3.1.2, and I wanted to downgrade to version 3.0 so I can use tethering hack from help.benm

    I downloaded the 3.0 firmware, plugged in my iPhone, held Shift + Restore button and selected the 3.0 firmware from the folder it was in. iTunes went through the whole process, and just as it's finished I get an error on iTunes saying and unknown error has occured and I'm back to square 1, except with a blank phone that only shows the 'plug into iTunes' picture.

    Why won't it work??
     
  2. cmoazz thread starter macrumors newbie

    Joined:
    Jul 22, 2009
    #2
    Anyone? Please help I've got a useless phone..
     
  3. cmoazz thread starter macrumors newbie

    Joined:
    Jul 22, 2009
  4. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
  5. cmoazz thread starter macrumors newbie

    Joined:
    Jul 22, 2009
    #5
    but I have the 3.0 firmware on my own...
    what's the lowest version that iTunes accepts?
     
  6. cmoazz thread starter macrumors newbie

    Joined:
    Jul 22, 2009
    #6
    Ok on the help.benm site it says the tethering hack will work on 3.1.3 but only with simlock? What does this mean, unlocked? If yes how do I unlock the phone? and does it matter that I unlock but still use at&t?
     
  7. benflick macrumors 68020

    benflick

    Joined:
    Jul 11, 2008
    Location:
    Cincinnati, Ohio
    #7
    That only applies with the 3GS, you can download to 3.0 on a 3G just fine.

    "Only with simlock" means that it only works on a locked phone.
     
  8. cmoazz thread starter macrumors newbie

    Joined:
    Jul 22, 2009
    #8
    Wow wow wow, wait a minute. Then why can't I get 3.0 to work? It says an unknown error occurred (1015). Then it goes back to plug into iTunes screen on the phone, and iTunes says it found a device that needs restore or something.

    So the benm hack works with 3.1.3 naturally on a AT&T locked iphone??
     
  9. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #9
    Well, I never could go back to 3.0. I eventually jailbroke, and now I can, but stock, no.
     
  10. cmoazz thread starter macrumors newbie

    Joined:
    Jul 22, 2009
  11. benflick macrumors 68020

    benflick

    Joined:
    Jul 11, 2008
    Location:
    Cincinnati, Ohio
    #11
    When you got error 1015, search for solutions on Google. There are different methods on how to get out of the error, that's what I did, an it worked fine for me.
     
  12. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #12
    See this, since he couldn’t point you to it:

    http://forums.macrumors.com/showthread.php?t=894207
     

Share This Page