Unknown 'Invisible' File Types

Discussion in 'Mac Pro' started by Framework, Mar 22, 2008.

  1. Framework macrumors newbie

    Joined:
    Mar 22, 2008
    Location:
    North of Scotland
    #1
    Hi,
    Just joined this forum - having viewed it for many months.
    You guys usually answer my questions without me having to ask but now I'd like some help if possible?

    I found files with these names in my side-bar:

    .de0129.2d6
    .de0129.2cd
    .de0129.2ca

    etc.

    I think my wife dragged them there by accident when she was using iPhoto.
    They are now in my Wastebasket but can't be seen and cannot be deleted as they are still in use.

    Any idea what they are and how to put them back to their proper place?
     
  2. yeroen macrumors 6502a

    yeroen

    Joined:
    Mar 8, 2007
    Location:
    Cambridge, MA
    #2
    Open up the terminal (Terminal.app), change to the directory the files are located (or in Finder, move these your home directory), and type

    fuser -u .de0129.2d6

    etc., That'll give you the PID's and user-id's of the processes that are using them. They're probably just temporary files created by some process for use as a FIFO or something, and so are safe to delete once you kill the process.
     
  3. Framework thread starter macrumors newbie

    Joined:
    Mar 22, 2008
    Location:
    North of Scotland
    #3
    Thanks for the quick response yeroen,

    I tried what you said but as the files are in invisible and in the trash, I can't move them anywhere.

    I managed to cd to this:

    ~/.Trash/.de0129.2d7/.de0129.2d6

    but when I tried your command, it says

    -bash: fuser: command not found

    Sorry to be a pain, but any other ideas? (I managed to find out that they were last opened on 5 Feb 2007 - so I'm obviously not using them much!)

    Thanks again
     
  4. martinlk macrumors member

    martinlk

    Joined:
    Jun 20, 2005
    Location:
    Aalborg, Denmark
    #4
    Hmmm. On my machine, fuser is only available in Leopard, not Tiger.
     

Share This Page