Unknown process. Need help

Discussion in 'OS X Yosemite (10.10)' started by iPaulie81, Nov 18, 2014.

  1. iPaulie81, Nov 18, 2014
    Last edited: Nov 18, 2014

    iPaulie81 macrumors newbie

    Joined:
    Mar 6, 2014
    #1
    Hi all

    I noticed in my activity monitor a suspicious process that is running. Can anyone tell me what this process is and if its safe or not? If it is potentially harmful can you tell me how to remove it. It seems to appear even after a system restart.

    Please refer to the process named http://shanghaiist.com/

    Sometime the process name changes to another website e.g. redrockethobbies.com. When I click on the process I get some information that inclues the following.... Process group: Spotlight Web Content (389).

    Thanks
     

    Attached Files:

  2. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #2
    It's a process run by e.g Safari! You are online on that website!

    [​IMG]

    In your case it's you doing a search in Spotlight for "shanghaiist"

    So no worries! :cool:
     
  3. iPaulie81 thread starter macrumors newbie

    Joined:
    Mar 6, 2014
    #3
    Thanks or the quick reply. The thing is I'm not on the website. Its not a website I have visited intentionally before.
     
  4. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #4
    Please post the screen that appears after you click-click on it in Activity Monotor?
     
  5. iPaulie81 thread starter macrumors newbie

    Joined:
    Mar 6, 2014
    #5
    here you go..
     

    Attached Files:

  6. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #6
    That's the output when you click-click on the http://shangaiist.com in AM?

    ----------

    If so you used Spotlight to look it up?
     
  7. iPaulie81 thread starter macrumors newbie

    Joined:
    Mar 6, 2014
    #7
    Yes thats its. Its changed to reddit.com now. Again, a site that I have not visited. I googled around since last night and apparently its due to some new spotlight feature that was introduced into 10.10. Still does not explain why it displays website that I don't visit.
     
  8. mac8867 macrumors 6502

    Joined:
    Apr 5, 2010
    Location:
    Saint Augustine, FL
    #8
    Ahhh html... you didn't visit that site, but the site you did visit pulled content from there. Your browser doesn't know the difference. Like the Add at the top of your screen right now did not come from macrumors.
     
  9. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #9
    I don't see any .com (not others) in my AM

    That seems a bit odd to me, when I visit macrumors with a browser without adblocker, I don't see any .com (not others) in my AM. Care to explain (to both of us) a bit more why the .com (or others) will show up AM? Thanks in advance!

    Cheers
     
  10. iPaulie81 thread starter macrumors newbie

    Joined:
    Mar 6, 2014
    #10
    But are you using Yosemite?
     
  11. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #11
    Yep, check my traffic light buttons in post #3! ;)

    OSX 10.10 (14A389)
     
  12. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #12
    I had the same thing going on and it was the Spotlight suggestions feature that caused it. I think what was happening is you would be looking for "receipt for TV" and start typing R E and SL suggestions would search the Internet and start to preload reddit.com and that would sit there in activity monitor exactly like you are seeing. I turned off the SL suggestions and it stopped.
     

Share This Page