Unlisted process using major percentage of cpu

Discussion in 'macOS' started by NP3, Oct 23, 2007.

  1. NP3 macrumors regular

    Joined:
    Jul 12, 2003
    Location:
    Los Angeles
    #1
    I noticed my CPU time was running between 50% and 100% according to my menubar monitor while I was just running Safari & Adium.

    Activity Monitor confused me more. It shows User percentage as 45% (the colored options at the bottom), while the list view showing all processes only has a highest value of 3%. (Often it was 90 and 3ish) While everything is fluctuating, the menubar monitor & User percentage would match.

    (Act. monitor refresh set to normal 2 seconds)

    My boot time was on 10 hours, and I had just run a complete Onyx run 3 days beforehand. (and no, spotlight wasn't indexing) No applications had been force quit either. I'm behind a software & hardware firewall.

    Whats going on here? It stopped after I logged out and back in...and this is the second time its happened.
     
  2. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #2
    What was the process ID of the offending application?
     
  3. NP3 thread starter macrumors regular

    Joined:
    Jul 12, 2003
    Location:
    Los Angeles
    #3
    Nothing is listed in Activity Monitor as offending, so I don't know. (forgot to try Terminal)
     
  4. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #4
    If you display all processes in AM, then sort by CPU usage, the worst contributor should be at the top.
     
  5. NP3 thread starter macrumors regular

    Joined:
    Jul 12, 2003
    Location:
    Los Angeles
    #5
    I took screenshots of it (can't figure out how to put them here)

    All Processes was selected. And Sorted by CPU%. Thus my confusion.

    The worst on top is Activity Monitor with 3.2%.
     

Share This Page