Unlock iPhone 3G | 4.0.1 | BB 5.12.04?!

Discussion in 'Jailbreaks and iOS Hacks' started by Krishna21, Oct 25, 2010.

  1. Krishna21 macrumors member

    Joined:
    Aug 29, 2010
    #1
    I'm buying my sister an iPhone today.

    iPhone 3G, she wants it on T-Mobile.


    It's on iOS 4.0.1 with baseband 5.12.04.

    Does anyone know how to unlock baseband 5.12.04?
    Google doesn't help because 5.12.04 isn't as common?

    I used SnowBreeze 2.0.2 and created a jailbroken firmware but have not restored it yet, since I want to know if I can unlock the phone or not.

    If anyone can help that'd be great :)


    thanks!!
     
  2. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #2
    I'm guessing you mean Baseband 5.13.04? If so, you can jailbreak a 4.0.1 firmware with jailbreakme.com and then install ultrasn0w 1.1 from Cydia and you should be fine. :)

    Apple started using a software SHSH with the iPhone 3G with 4.x firmware, so unless they are on file with Cydia, I don't think you can restore a 4.0.1 firmware.

    With that said, I have heard 4.1 does better on an iPhone3G with the performance improvements so I would recommend you use Pwnage Tool to package a 4.1 custom firmware and restore with iTunes to the custom firmware. This will ensure you have the latest software and keep your baseband at the unlockable 5.13.04 version. :) From, there you can download ultrasn0w. Lately, don't forget to turn off 3G in your Settings.
     
  3. Krishna21 thread starter macrumors member

    Joined:
    Aug 29, 2010
    #3

    Nope..5.12.04
     
  4. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #4
    You can do everything you want to do with the existing firmware and baseband. Jailbreak with jailbreakme.com and then go to repo666 and unlock with ultrasn0w. The 5.12 baseband is the one that came with 3.1.3 so whoever updated the phone must have Jailbroken it and retained the previous baseband.
     
  5. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #5
    You sure? Baseband for 3G was 5.12.01 at 3.1.2 and 5.13.04 for 4.0. It's gotta either be 5.12.01 or 5.13.04. :)
     
  6. Krishna21 thread starter macrumors member

    Joined:
    Aug 29, 2010
    #6
    Ok, thanks!!
    Ultrasn0w .93 or the most recent on Cydia right now, 1.1-1?
     
  7. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #7
    You could, but would you want to? I have read that 4.0.1 runs really slow on a 3G, hence Apple's 4.1 update. I'm actually asking here since I have some old 3G's around that I want to give to family. :)
     
  8. Krishna21 thread starter macrumors member

    Joined:
    Aug 29, 2010
    #8
    I don't see why people are complaining about iOS 4 and Speed on iPhone 3G.

    The iPhone I was concerned with on 4.0.1 runs fine, and my iPod Touch 2G runs 4.1 Jailbroken is great :)


    But one app I reccomend staying away from on non-A4 devices would be Intelliscreen..it was so slow and didn't even work, lmao
     
  9. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #9
    Use the latest version of ultrasn0w on Cydia. My opinion is that the 3G works best on 3.1.3 but if you are happy with it on 4.0.1 then there is no problem with staying there.
     
  10. Krishna21 thread starter macrumors member

    Joined:
    Aug 29, 2010
    #10
    Awesome :)
    Thanks to everyone who helped!

    If I update to 4.1 and still have BB 5.12.04, can I simply use Sn0wBreeze 2.0.2 and create a custom IPSW (with a custom boot pic :D), and then restore with it in iTunes?

    Then simply use ultrasn0w in cydia after installation?

    that would work, right?
     

Share This Page