Unlock iPhone 4 on 4.0.2 with 1.59.00 baseband

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Constantine!, Mar 24, 2012.

  1. Constantine! macrumors newbie

    Joined:
    Mar 24, 2012
    #1
    Hey guys,

    I'm getting alot of mixed answers researching about this everywhere. Most of the stuff is outdated. So here's my situation:

    I have a iPhone 4 on 4.0.2 firmware with 1.59.00 firmware. I am with T-mobile so I want to unlock this iPhone 4. I hate gevy sim crap, I want to unlock using the original T-Mobile sim.

    So we are in year 2012, so is this possible to jailbreak and unlock this iPhone 4? If so using what?

    Thanks fellas!
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Yes.
    You can jb with jailbreakme.com and unlock with ultrasnow from cydia.
    Make sure you don't lose that unlockable baseband. It is very valuable.
     

Share This Page