Unlock/Jailbreak - Need serious help!

Discussion in 'Jailbreaks and iOS Hacks' started by MatrixClaw, Jan 14, 2009.

  1. MatrixClaw macrumors newbie

    Joined:
    Jan 14, 2009
    #1
    I got a 16gig 2G iPhone yesterday and I've been trying since 10 this morning trying to unlock and jailbreak it to work with T-Mobile, but nothing is working!



    When connected to iTunes, it finds my iPhone but says it doesn't have a SIM card in it, I click OK and the iPhone is not recognized.

    If the phone is in Restore Mode, iTunes recognizes it, but only shows the serial number, no firmware version, etc. Will let me click "Restore."

    With my T-Mobile SIM installed, it says that the SIM inserted does not work with the iPhone and doesn't show anything else. It also shows, on the phone itself, T-Mobile on the top left hand corner.


    Originally, I tried to use Ziphone to unlock/jailbreak it (Using Windows XP SP3), but it seems this only works with older firmware, and would hang in "Starting Recovery Mode," or something like that. I then tried QuickPwn 2.1 and 2.2, everything goes smoothly until the DFU part, in which case, my phone will not enter DFU.

    I called a friend over, who's done unlocking on his and a few other friend's iPhones many times before, and we took it to his house and tried it on his Mac using Pwnage Tool 2.2, 3.0 and QuickPwn 2.2. Everytime, on each one, it failed to enter DFU mode.



    The previous owner told me it's been unlocked and jailbroken before, but just got tired of having to do it everytime a new version would come out, as he's not computer-savvy.

    What exactly am I doing wrong here? This is getting really annoying :(
     
  2. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #2
    is your Mac updated to 10.5.6? if so, this is your problem. Search the forum and you'll see folks with similar behavior. :)
     
  3. Limb macrumors member

    Joined:
    Aug 30, 2007
    #3
    Sounds like he himself is actually on a Windows based machine.
     
  4. MatrixClaw thread starter macrumors newbie

    Joined:
    Jan 14, 2009
    #4
    Exactly. I'm on Windows XP SP3, my friend is on OSX, not sure what version, but it recently worked when he unlocked another iPhone.
     
  5. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #5
    I guess I got confused when I read:
    :)
     
  6. neesh0 macrumors 6502a

    neesh0

    Joined:
    Sep 6, 2008
    Location:
    Toronto, Ontario
    #6
    try restoring the phone with 2.2 on the newest version of itunes, then try again. good luck!
     
  7. MatrixClaw thread starter macrumors newbie

    Joined:
    Jan 14, 2009
    #7
    Going to try this again.

    The only way I've been able to get the phone into restore mode is by Ziphone forcing it :(
     
  8. MatrixClaw thread starter macrumors newbie

    Joined:
    Jan 14, 2009
    #8
    I restored to 2.2 last night and it was doing the same thing, however, this morning my computer seems to be recognizing that it's in DFU mode by beeping, nothing will show on the screen, but neither iTunes nor QuickPwn recognizes this.
     

Share This Page