unlock keychain at start up.

Discussion in 'macOS' started by emdotdee, Mar 8, 2006.

  1. emdotdee macrumors regular


    Nov 6, 2003
    Widnes, Cheshire, England.
    hello everyone, hoping someone can help me.

    Every time that i start my computer up and go to an application that requires a password (eg adium, mail, safari) i get a pop up that asks me to unlock my keychain. it's done this for a very long time but has only just started to cause a problem. sometimes when i open an application at start up the pop up for the keychain password doesnt appear and causes the application to freeze and requires a restart to fix the problem.

    is there any way i can stop it from needing to ask me?

    i've tried unlocking the keychain and then restarting - didnt help
    tried deleting my keychain and starting a new one - didn't help
    tried verifying and reparing the keychain - didn't help

    i could really do with some help regarding this annoying and frustrating problem, thanks

    using an iMac g4 with osx 10.3.9
  2. Mitthrawnuruodo Moderator emeritus


    Mar 10, 2004
    Bergen, Norway
    The only thing I can think of is to move/rename/delete the ~/Preferences/com.apple.keychainaccess.plist file and reboot... then unlock the keychain and see if it stays unlocked...

    ...another thing is to login to another account (make one if you must) and see if the keychain in that account behaves better...

    Also: In Keychain Access preferences, check the Show Status in Menu Bar. Makes locking and unlocking easier... :)
  3. csunnn macrumors newbie

    Dec 26, 2008

    Man I hate having to register for a forum simply to add to the school of mac thought!

    Ok, your problem is that the keychain file has been corrupted. Here's your solution:

    1) Close all programs.
    2) Click your FINDER icon > Library > Keychains >
    2) Now trash the .keychain file that you see and empty the trash.
    3) Open safari (the program that normally is the problem here)
    4) When it asks, reset safari (or keychains, I can't remember which it is).

    You're system is now back to normal.
    word up, and peace to the middle-east.


  4. amchase macrumors newbie

    Oct 25, 2009
    keychain corrupted

    This worked for me. Running 10.3.9. Just reinstalled system on old Powerbook G4 and added a network card (seen as an airport card by the system). Could not get on the internet--Safari and iCab freezing or quitting on me. Or I would get messages saying I couldn't access page because of security problems. Firefox wouldn't even load. Deleted the user file in Finder>Library>Keychains. It wasn't a .keychain file. File was my username for my computer. I reset Safari, though this fix worked for all the browers...BUT, I highly recommend downloading the latest version of Camino. It's supported and displays all websites accurately, unlike Safari and iCab (didn't try Firefox again).

Share This Page