Unlock macOS with Apple Watch?

Discussion in 'macOS Sierra (10.12)' started by 212rikanmofo, Jun 17, 2016.

  1. 212rikanmofo macrumors 65816

    Joined:
    Jan 31, 2003
    #1
    I saw this being demo'd at WWDC 2016, but I can't get it to work. Is there some kind of setting that we must enable?
     
  2. treichert macrumors 6502

    Joined:
    Nov 7, 2007
    Location:
    Aachen, Germany
    #2
    It's not yet available. See the release notes.
     
  3. spooky2k macrumors 6502a

    spooky2k

    Joined:
    Apr 14, 2008
    Location:
    UK
    #3
    Read your release notes that come with the software. This, and many other things, aren't in the beta along with lots of issues. If you're going to jump on to a beta, be smart enough to read what you're getting in to and be informed.
     
  4. Phil in ocala Suspended

    Phil in ocala

    Joined:
    Jul 14, 2016
    #4
    THIS falls into the philosophy of "lets make everything as complicated as possible...lets outdo Microsoft"
     
  5. nylon macrumors 65816

    nylon

    Joined:
    Oct 26, 2004
    #5
    You have to have two-factor (Note: not two-step verification) authentication setup on your iCloud account for this to work.

    Once you have it setup it works perfectly.
     
  6. andyt3 macrumors member

    Joined:
    Feb 2, 2016
    Location:
    Western MA
    #6
    I disabled two factor verification about 15 minutes ago.

    Still, when trying to enable it within Security & Privacy I still get the notification that I need to disable two factor verification. Hmm, maybe sooner than later it will catch up...
     
  7. nylon macrumors 65816

    nylon

    Joined:
    Oct 26, 2004
    #7
    If you have "Two Step" verification activated on your iCloud account you have to first disable that by logging into your Apple ID account at http://appleid.apple.com.

    Then you have to activate "Two Factor" authentication on an iOS device. - https://support.apple.com/en-ca/HT204915
     
  8. hpman247 macrumors regular

    Joined:
    Jun 6, 2011
    #8
    I setup 2FA two weeks ago in preparation for this. I didn't even have 2 step verification on, so I just turned 2FA on, and this works brilliantly. :D
     
  9. andyt3 macrumors member

    Joined:
    Feb 2, 2016
    Location:
    Western MA
    #9
    Oops, got the two confused haha.

    A few clicks, and all is well.
     
  10. dimzen macrumors regular

    dimzen

    Joined:
    Nov 11, 2011
    Location:
    Denmark
    #10
    Thanks, got one more step forward, but now when I try to active Watch unlock, it hangs with "activating" and a spinning circle :/
    (I have my Mac set to Danish..)
     

    Attached Files:

  11. gppittjk macrumors regular

    Joined:
    Sep 19, 2012
    #11
    Ok I have an AW on wOS3 and an early-2013 rMBP on mOS Sierra. I have 2FA on for my iCloud account. But the option to enable unlock with Apple Watch still does not appear for me. Am I missing something?
     
  12. nylon macrumors 65816

    nylon

    Joined:
    Oct 26, 2004
    #12
    Try rebooting your machine as well as your iOS devices/Watch. Mine worked straight away.
     
  13. ncx5 macrumors newbie

    Joined:
    Aug 4, 2008
    #13
    I have early and it's missing as well. I saw an article where it's only supported on Late 2013 models, can't recall. Hopefully some will create a patch as it was available in the earlier betas.
     
  14. nylon macrumors 65816

    nylon

    Joined:
    Oct 26, 2004
    #14
    Make sure you have a supported machine for this feature. I believe your Mac needs to be a model from 2013 or newer. Edit: Just saw you are on a 2013 rMBP. Option should show up under system preferences/security settings.
     
  15. gppittjk, Sep 20, 2016
    Last edited: Sep 20, 2016

    gppittjk macrumors regular

    Joined:
    Sep 19, 2012
    #15
    They don't show up. I've signed out and back into iCloud on my phone and my computer. I guess we're gonna get an update in a few days from Apple that "woops, we meant late-2013 or newer."

    Edit: I tried searching for the setting, and according to the screenshot below, it is hidden. Any ideas how to fix this? My watch is paired to my phone. Do I need to BT pair it to my computer?
     

    Attached Files:

  16. nylon macrumors 65816

    nylon

    Joined:
    Oct 26, 2004
    #16
    Strange message. I hope it is compatible and it's just a glitch. Or it could be that the machine is not supported. Cross fingers.
     
  17. old-school macrumors 6502

    Joined:
    Sep 2, 2009
    Location:
    UK
    #17
    I've got the same problem. rMBP Mid 2015. Sierra and WOS 3 installed.

    Had 2 step setup before, just enabled 2FA
     
  18. gppittjk macrumors regular

    Joined:
    Sep 19, 2012
    #18
    Do you get the same message when you search for Apple Watch in System Preferences?
     
  19. old-school macrumors 6502

    Joined:
    Sep 2, 2009
    Location:
    UK
    #19
    Yes, I get the same thing. I could see the option when I had 2 step enabled. I disabled 2 step, then enabled 2 Factor and now it's gone. Quite annoying. I read that you need to be on the same wifi and have bluetooth enabled which I have. Don't really fancy setting my watch up from scratch to see if it'll work. Should have been straight forward as I have all the latest hardware. Copy and paste works fine.
     
  20. jamdex macrumors member

    Joined:
    Jul 8, 2012
    Location:
    Manchester UK
    #20
    Has the same problems, rebooting the Apple Watch sorted it.
     
  21. old-school macrumors 6502

    Joined:
    Sep 2, 2009
    Location:
    UK
    #21
    Thanks, rebooted mac and watch and that's brought the option back; just pairing now. When the watch rebooted the iPhone asked me again for iCloud password so I think it might be to do with the watch needing authorisation.
     
  22. John6Plus macrumors 6502

    John6Plus

    Joined:
    Sep 19, 2014
    Location:
    Holland, MI
    #22
    I just had the problem where my Mac would say, "Unlocking with Apple Watch," spin for a few seconds, then prompt me with a password. I discovered that the problem was my watch wasn't connected to my wifi. Now, I would argue that it should have worked with just Bluetooth, but whatever. I followed the steps on this page:

    http://www.iphonehacks.com/2015/05/how-to-ensure-apple-watch-is-connected-to-a-wi-fi-network.html

    And got my watch to connect to Wi-Fi, which it finally did. (I've actually had this problem forever on my home network but just figured my watch was too far away from my router.) Now it works like a champ.

    A little bit of info would've been nice, but, then they wouldn't be the Apple we know. :|
     
  23. CrackerJackToy macrumors 6502

    CrackerJackToy

    Joined:
    Nov 1, 2011
    #23
    Are you guys sure about the 2012 rMBP not being supported? I read somewhere today it was. And when I search 'Apple Watch' in the settings, I see the same screen shot posted above, where it says 'Allow Apple Watch to Unlock the Computer Setting'. So its clearly hidden on my machine. I have restarted everything 3x with no avail. However, my 2015 iMac shows it no problem and works fine! Obviously I have two factor auth enabled.
     
  24. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #24
    2013 and later only, I believe.
     
  25. CrackerJackToy macrumors 6502

    CrackerJackToy

    Joined:
    Nov 1, 2011
    #25
    I wonder why I get that message saying its hidden then...
     

Share This Page