Unlock Problems: Ultrasnow 1.2.5 on iPhone 4 (01.59.00)

Discussion in 'Jailbreaks and iOS Hacks' started by mustnotsleep, Apr 26, 2012.

  1. mustnotsleep macrumors 6502

    Joined:
    Apr 3, 2010
    #1
    I have an iPhone 4 with a 01.59.00 baseband running iOS 4.0.1 (i dont upgrade often) with ultrasn0w 1.2.5 and I keep getting "SIM Invalid" or something similar as an error. I recently switched to a new T-Mobile SIM card from an older T-Mobile SIM under the same iOS and managed to unlock and use the previous SIM so I am unsure of the problem. I have restarted and uninstalled/reinstalled ultrasnow dozens of times and I have reset network settings so all of that is blank, but nothing seems to work. The SIM card I am using now came as a microSIM (so no cutting issues) and the account is activated already. Any ideas?
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Maybe a faulty sim?
    You turned off 3G in settings?
     
  3. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #3
    Like said about make sure 3G if off. Could be something at fault with the iPhone.
     
  4. mustnotsleep thread starter macrumors 6502

    Joined:
    Apr 3, 2010
    #4
    3G is off. This is actually the second SIM I have tried, the first was a regular SIM that I cut myself that did not work so I got a new one from the T-Mobile store (said I had lost mine). Neither has worked in spite of repeated restarts and uninstalling/reinstalling.
     
  5. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #5
    Have you tried the sim in another phone? Make sure it works in another phone. If it does, then you'll know for sure it's your phone.
     
  6. b0bab0i macrumors regular

    Joined:
    Jan 10, 2012
    #6
    If you have an iPhone with 1.59.00, pretty sure your phone is old enough to contact AT&T for a carrier unlock, then you will never have to worry about unlock problems ever again.
     
  7. Minhimalism macrumors 65816

    Minhimalism

    Joined:
    Jan 6, 2012
    Location:
    Texas
    #7
    I KNOW THE ANSWER TO THIS (I swear). The new SIMs that T-Mobile are offering are 4G SIMs, they're a fresh roll out. Now, I haven't tested any of them in my family's factory unlocked iPhones, but all I can tell you is that they DO NOT WORK in any circumstance with Gevey. Only the 3G SIM that T-Mobile offered, and before, work. I'm not sure why this is the case, but maybe the incompatibility also applies to the baseband unlock.

    EDIT: TL;DR, it's a SIM incompatibility issue. I tried three new 4G SIMs in my sister's iPhone 4 running a Gevey and they were never read at all. The 3G SIM I went and bought and activated was read immediately. Again, no clue if this applies to ultrasn0w unlocks, but that might be it!
     
  8. mustnotsleep thread starter macrumors 6502

    Joined:
    Apr 3, 2010
    #8
    Where do I obtain an older T-Mobile SIM card. Do you think they would have them in stock at the T-Mobile stores if I were to ask?
     
  9. Minhimalism macrumors 65816

    Minhimalism

    Joined:
    Jan 6, 2012
    Location:
    Texas
    #9
    Most of the T-Mobile stores don't. One that I asked said I was basically antique hunting. Go to a third party authorized dealer, pay the small fee they charge, and you should have a working, older SIM. Make sure you specify what you need!
     
  10. mustnotsleep thread starter macrumors 6502

    Joined:
    Apr 3, 2010
    #10
    Your postulate about the phone being incompatible with the 4G SIM cards is invalid. I managed to get the same micro-SIM working instantly with a itunes restore and a factory unlock from AT&T.
     

Share This Page