Unlocked 1.1.4 to 2.x Help please

Discussion in 'Jailbreaks and iOS Hacks' started by Havok1327, Aug 8, 2008.

  1. Havok1327 macrumors newbie

    Joined:
    Aug 8, 2008
    #1
    I apologize for the post, usually I'd search around for what I'm trying to find but time is working against me right now.

    I ran across a deal on the 1st gen iPhone running 1.1.4 and unlocked. This is my 1st iPhone and I'm going to need it to run the 2.0 firmware to get the Exchange sync feature for work and I'll need to keep in unlocked to use on T Mobile which is our corporate standard for phones.

    Will this be possible?

    I'm meeting up with the guy in a bit so a quick answer would be very much appreciated!

    <Matt
     
  2. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #2
    Do it dude, you're set. For a first gen iPhone, you will be perfectly fine upgrading to 2.0 and unlocking.
     
  3. Havok1327 thread starter macrumors newbie

    Joined:
    Aug 8, 2008
    #3
    Wow now that's a quick answer, thanks!

    I'm assuming I'd just download the 2.0 firmware, install it then use the pwnage tool to jailbreak and unlock it again. Is that correct? I want to stay away from 2.0.1 right?
     
  4. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #4
    The new PwnageTool that adds compatibility with 2.0.1 should be released today, so you should be good no matter what.
     
  5. Havok1327 thread starter macrumors newbie

    Joined:
    Aug 8, 2008
    #5
    Awesome!

    At any point will I need an AT&T Sim to unlock it again? I'll have to dig one up if I do.

    I'm off to pickup the phone.
     
  6. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #6
    I don't think you'll need the actual AT&T SIM, but most of the ones I've unlocked have stayed with AT&T (non-iphone plans). Someone else may know better about T-Mobile specifically, but I don't think it'll be an issue
     
  7. Havok1327 thread starter macrumors newbie

    Joined:
    Aug 8, 2008
    #7
    Well I have the phone in hand now.

    Its very nice! I don't think I'll be getting much work done this afternoon. :)

    I'll do some reading on it when I get home and see if I'm going to have to jump through any hops when I upgrade to 2.0.1
     
  8. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #8
    Wait till tonight to unlock/jailbreak it, get the new version of PwnageTool. The dev team just updated their blog, and it looks like the new version will drop any minute

    EDIT: If you download PwnageTool, you can now update from the built-in updater. This adds support for the latest iPhone firmware (2.0.1)

    EDITx2: lol nvm, it isn't up yet, a few more hours maybe
     
  9. Havok1327 thread starter macrumors newbie

    Joined:
    Aug 8, 2008
    #9
    Well I couldn't wait any longer :) and followed the walk through I found and have the phone upgraded to 2.0. thanks for all the help!
     

Share This Page