Unlocked 3GS won't turn on after Cydia update~ Help needed!

Discussion in 'Jailbreaks and iOS Hacks' started by enochpeng, Nov 15, 2009.

  1. enochpeng macrumors regular

    Jan 22, 2008
    Thank you for taking your time to view my post and possibly helping me!

    My phone is about a month old and it's a Rogers iPhone 3GS 16GB

    I jailbroken it using Dev-Team's method and than unlocked it using blackra1n.

    Last night, I did a complete update in Cydia, and was told to reboot the device, I did so.

    After that, my iPhone will only stay on the Apple logo screen for 10-20 second, and then shuts itself off again. I tried to reboot more than 30 times and tried to connect to my mac, same story......

    Is there anyway I can restore it w/o the need to see it in iTunes??

    I'm so upset now.... So any input or tips would be much much appreciated~!

    Thanks everyone again!
  2. jmann macrumors 604


    Dec 8, 2007
    bump on a log in a hole in the bottom of the sea
    Did you update mobile substrate? That has been causing problems with people. I would suggest restoring the phone in iTunes and rejailbreaking it. Is there a reason you don't want/can't use iTunes? It is required to do a restore.
  3. enochpeng thread starter macrumors regular

    Jan 22, 2008
    Thanks mate, pardon me I didn't describe it clearly.

    My phone won't even turn on now, will only stay on the apple logo screen for a while. So essentially I can't connect it with iTunes...

    any idea?
  4. bytethese macrumors 68030


    Jun 20, 2007
    Cranford, NJ
    You might have an iPhone with the updated iBoot, which means you can only do a teathered jailbreak. Check to make sure. :)
  5. enochpeng thread starter macrumors regular

    Jan 22, 2008
    Thanks for your help, but how can i do so? and does it require the iphone to been seen in iTunes and connected to the computer or completely turned on...
  6. iPhone-power macrumors 6502a

    Nov 12, 2009
    You put the phone in DFU mode

    Here is a thread on how to check

    Don't forget about Google
  7. lucyg macrumors newbie

    Nov 24, 2009

    Please let me know if you were able to fix it and how. I had the exact same problem. :(
  8. iPhone-power macrumors 6502a

    Nov 12, 2009
    There is no fix for this. For the new bootrom the jailbreak is a tethered jailbreak. It requires a computer, USB cable and copy of Blackra1n to restart or reboot every time !

Share This Page