Unlocked iPhone 3G not reading any sims

Discussion in 'Jailbreaks and iOS Hacks' started by leglez, Nov 30, 2009.

  1. leglez macrumors newbie

    Joined:
    Mar 19, 2009
    #1
    I have a 3G iPhone that I have had since July and its been unlocked since I have owned it. It is running 3.1.2. I was cleaning my house today and found an old sim card so I put it in the iphone to see if there were any old numbers on it I needed. It wouldn't read it so I put my old card back in and it now won't read that. I tried my girlfriends sim and it wont read it either. I have put my sim in another tmobile phone and it works fine. I have tried to hard start it, restore from a backup, sync, and restart it. I have blown into the sim card tray to try to clean it out of dust and I have wiped down the sim card. Nothing is working, and it is out of warranty. Anyone have any suggestions?
     
  2. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #2
    I doubt it's your unlock, but it's possible. The only basic troubleshooting step you haven't tried is a full restore and set up as new phone (not restore from backup). Give that a try and see if you can activate your phone.
     

Share This Page