Unlocked/JB iPhone 4 - what do I do before a restore?

Discussion in 'Jailbreaks and iOS Hacks' started by BIS2, Jun 20, 2012.

  1. BIS2 macrumors regular

    Joined:
    Jun 20, 2004
    #1
    I have no clue about unlocking and jail breaking so I'm hoping someone here can clarify for me.....

    I have an iPhone 4 (1.59, 5.0.1) unlocked/jailbroken running on Tmobile. The person I bought the phone from on Ebay was kind enough to contact At&t and ask them to unlock it for me - At&T confirmed to them that the phone was unlocked, and sent the restore directions. I also called Apple, who told me the phone is now unlocked. And, dev.mk reports that it's unlocked. Fantastic right?

    I tried plugging the phone into my computer and was hoping to get the Congratulations, you're unlocked message but I did not. I'm worried about restoring because I'm afraid something is going to go wrong and it will update the baseband and I'll be out of luck. I've read something about deactivating redsnow or SAM - is it safer if I do this first, then restore and make sure I get the unlock confirmation? Do I need to use one of these vs the other based on how the phone was unlocked? How do I even know the method used to unlock it? I've read tutorials but using either of these methods to deactivate scare me some since I know nothing about this and see people talking about problems with DFU mode.....I don't even know what that is!

    I honestly do not care at all if the phone is jailbroken, I only wanted that to be able to use it on Tmobile so if that goes away it's fine. Please tell me how I should proceed....

    Thanks!!
     
  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #2
    Uninstall ultrasn0w


    Use SAM.

    deactivate the phone, than connect to itunes, on my AT&T Unlocked ip4 it didn't give the congratulations message, but it was unlocked.

    You will have the 1 signal bar cosmetic issue, but the phone will work.

    After you checked it on 5.01/1.59.00 you can use restore to stock 5.1.1
     
  3. BIS2 thread starter macrumors regular

    Joined:
    Jun 20, 2004
    #3
    Ok so just to clarify......if I use SAM that will uninstall ultrasnow? Or do I need to do something different to do that?

    Would this be a good tutorial to follow for SAM?

    http://www.iclarified.com/entry/index.php?enid=13089

    Also - you said yours didn't say congrats your unlocked.....so how did you know that you were and it was safe to restore?

    Thanks a lot

    ----------

    Uh oh.....just did a search for info about SAM and it says that as of the end of April this will no longer work?
     
  4. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #4
    Uninstall ultrasn0w in Cydia.

    After that use SAM to deactivate your phone.

    When i uninstalled ultrasn0w my phone worked so it was unlocked, 2 days later i received the confirmation email from AT&T.
     
  5. BIS2 thread starter macrumors regular

    Joined:
    Jun 20, 2004
    #5
    Ok, I see ultrasnow, and I think if I click modify I can uninstall that right?

    But I still don't get the SAM thing - I have read in several places that Apple disabled it last month.
     
  6. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    SAM was designed as a way to "repair" push notification 2 years ago, earlier this year it was discovered that with SAM you could unlock SIM locked phones, the last part was fixed by apple, the original purpose of SAM still works including deactivating the phone
     
  7. BIS2 thread starter macrumors regular

    Joined:
    Jun 20, 2004
    #7
    Ok I think a lightbulb just went on and I get it now.

    1. Since phone is already unlocked via ultrasnow, I'm not getting a congrats you're unlocked message

    2. To get the message and confirm that it is truly unlocked, I need to uninstall ultrasnow and use SAM to deactivate the unlock

    3. This will sort of reset the phone and then when I plug it in to iTunes it should hopefully tell me its unlocked, or at the very least it should just work with my tmobile sim

    -QUESTION: I don't run a risk by doing this b/c the phone will not update it's firmware unless I do the restore right?

    4. Once I confirm it's unlocked, I can do the restore (or, I guess if it works that way I don't need to?)

    5. If I don't care about the jailbreak I can just restore the phone and I will lose the jailbreak but will have an unlocked phone since at&t/apple have done their thing

    One other question - if I screw something up with the ultrasnow/SAM thing the worst that could happen is I need to re-unlock it (if for some reason the official unlock is not working)?

    Ok I'm a little slow with this but am I getting it now??
     
  8. TriJetHero, Jun 20, 2012
    Last edited: Jun 20, 2012

    TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #8
    1 almost, because it is already activated you won't see the message. If you are not jailbroken they only way to deactivate is to restore, now that you are jb-en you can deactivate with SAM without restoring.

    2 deactivating an reactivating and still have ultrasn0w would defeat the purpose of the unlock, it will work anyway. To check if it is really unlocked, uninstall ultrasn0w, if it still works its unlocked permanently.

    3 Yes

    Correct, no risk

    4 Yes, although with 5.01 without ultrasn0w you will have a cosmetic issue, your signal bar will be stuck on 1 bar, because of a mismatch between 5.01 and the 1.59.00 BB, they don't belong together. If you upgrade later on to to 5.1.1 it will be solved.

    5 Yes, but you can rejailbreak 5.1.1 with absinthe 2.04.

    You can reactivate with SAM reinstall ultrasn0w, you'll be back as you were.
     
  9. BIS2 thread starter macrumors regular

    Joined:
    Jun 20, 2004
    #9
    Ok as I feared......I screwed it up.

    I went to Cydia and in ultrasnow I clicked "remove"

    When that was done, I got a message saying the phone could not activate cellular data on the network and where it lists the network name it now says no service.

    I panicked and here is where I probably did something dumb....since some people say just uninstalling ultraslow is enough, I thought I should try that so I plugged into iTunes. I then got a message saying "iPhone failed to activate, try later" and on the phone it says "activation required."

    It turned on wifi, and now when I unlock the phone it wants me to chose a network.....it looks like it's in setup mode because it has that gray lined background.

    I obviously should have just followed directions and done SAM, but I'm confused b/c it seems like the phone is deactivated anyway, so why isn't this working?? Help? I now have no phone whatsoever. I'm a moron!!
     
  10. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #10
    You must have done a bit more than just connect it to itunes.

    Removing ultrasn0w will indeed cause the no service.
    It does nothing to your activation.

    Connecting to itunes at that point does not do anything either.

    Did you restore?
     
  11. BIS2 thread starter macrumors regular

    Joined:
    Jun 20, 2004
    #11
    No, I didn't do anything but plug it in to iTunes. It took a minute or 2 for it to load the phone, then I got the failed to activate, try later message, and on the phone a little box popped up saying activation required (that went away after I unlocked the phone (via slider on lock screen).....all I can get now is it asking me to choose a network, but I don't want to do that because I don't want it to update anything wirelessly since I won't know what it's doing......

    Should I try taking the sim out? Powering off & then on? Try iTunes again? At this point I'm too nervous to do anything!
     
  12. BIS2 thread starter macrumors regular

    Joined:
    Jun 20, 2004
    #12
    ps I could not restore in iTunes even if I wanted to because when I clicked on the iPhone, instead of giving me the menu on the right it just gave me a blank white screen. Should have taken a screen shot I guess.
     
  13. TriJetHero, Jun 20, 2012
    Last edited: Jun 20, 2012

    TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #13
    Take out the SIM and try again.

    Did you personally talk to Apple that it is unlocked.
     
  14. BIS2 thread starter macrumors regular

    Joined:
    Jun 20, 2004
    #14
    Apple, at&t, and dev.mk all say the phone is unlocked.

    I just read about the outage with apple's servers yesterday. I guess that was primarily related to iMessage, but it was right around the same time as my problem. I wonder if that could be related?
     
  15. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #15
    Having Ultrasn0w installed does not interfere with the IMEI unlock being applied to the phone.
    It can just be removed after the IMEI unlock is successfully applied.
     
  16. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #16
    You didn't deactivate the phone, without ultrasnow it recognizes a non-approved sim and disallows use of the phone.

    2 options:

    - either borrow an AT&T microsim from somebody, any att wil do even old ones currently not in use. Insert and it will give access again. After that run SAM to properly deactivate

    Or

    - with redsn0w rejailbreak the phone and select activate during jailbreak process. Than install and run SAM again to deactivate it properly.
     
  17. BIS2 thread starter macrumors regular

    Joined:
    Jun 20, 2004
    #17
    Finally decided I did not need the stress of trying to figure this out myself anymore so I went to an iPhone repair place. They worked their magic and I now have an officially unlocked iPhone! No longer jailbroken but clearly that was not something I needed to be messing with anyway.

    Thank you so much for your help!
     
  18. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World

Share This Page