unlocking a 3G - important question

Discussion in 'Jailbreaks and iOS Hacks' started by rapidj, Oct 17, 2009.

  1. rapidj macrumors regular

    Joined:
    Mar 6, 2003
    #1
    hi folks, I am going to buy a 3G from a friend and then unlock and jailbreak. what should I be looking for in terms of what system software it should be running or even baseband if that matters. I just need to know what to ask her and how she can check. I don't want to get one that's been updated so far along that it can't be unlocked or jailbroken.

    I currently have a 2G that i have jailbroken and unlocked and am running 3.0 with no problems.

    thanks in advance

    Kory
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    If you expect to unlock it, it will have to have baseband 4.26.xx. If it has 5.11.xx it cannot be unlocked.

    Look in Settings/General/About all the way at the bottom of the page to find baseband.

    Don't update the firmware to 3.1 or 3.1.2 (except thru Pwnage Tool) or you cannot ever unlock it.

    I have given you enough info to start.

    Use Google now and do some reading.
     
  3. rapidj thread starter macrumors regular

    Joined:
    Mar 6, 2003
    #3
    Thanks for the help. I did do some research but I was getting confused with what seemed like conflicting info. My friend just got back to me with the info. The version is 3.1.2 and the baseband is 05.11.07. Just so I'm clear, this phone cannot be unlocked until developers come up with a new work around, is that correct?.

    Thanks again
    Kory
     
  4. gogel-geek macrumors newbie

    Joined:
    Oct 14, 2009
    Location:
    Edison, NJ USA
    #4
    Not necessarily so.
    You also need to check the Bootloader version.
    This can only reliably be done on a Jailbroken phone using Fuzzyband.
    If your Bootloader version as reported by fuzzyband is 05.08 [G2M3S2] or lower it's possible that fuzzyband can downgrade the Baseband to ICE2-04.26.08 which would allow unlocking with ultrasn0w.

    You can possibly get an idea of the Bootloader version by checking the manufacture date of the phone. This is coded into the serial number, for example if the first 5 digits of the S/N are 84811XXXXXX it means that the phone was built in factory 84 (first two), in 2008 (third) during the 11th week of the year (4, 5th digit).
    It's believed (someone please clarify further) that 3G phones built early in the cycle (before August 2008) have the downgradeable 05.08 Bootloader and can be successfully downgraded and unlocked.

    Please jump in if I'm wrong about this...
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    Yes, 10% of the first released 3G phones had bootloader 5.08

    If you do JB the phone, download Fuzzyband thru Cydia, it will tell you if the baseband can be downgraded.

    Just a hunch, but you friend may be selling his phone because he updated it and the baseband cannot be unlocked, so choose wisely.
     
  6. rapidj thread starter macrumors regular

    Joined:
    Mar 6, 2003
    #6
    No, it's a situation, where she can now upgrade to the 3GS. She doesn't know much about the upgrades. She mostly lets her son upgrade for her. No doubt her son has been upgrading every step along the way. Too bad, she was going to give me a real good price to

    thanks
     

Share This Page