Unlocking Folder

Discussion in 'macOS' started by ktalebian, Dec 30, 2007.

  1. ktalebian macrumors regular

    Joined:
    Dec 25, 2007
    #1
    Hi
    I have my external hard drive connected. I could previously copy/delete/write anything to it. However, now, one of the folders is locked (just the one) and I cannot copy or delete or write to that folder.
    When I go to Get Info, I cannot undo the check box next to the unlock.
    I even tried to lock another folder, but I can't even lock another folder.
    I did a google search and saw some similar problems. I tried all of their solutions, but nothing worked.

    Why?
    Thanks
    kousha
     
  2. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #2
    It is probably owned by a different user. Are you using a different user now or have you set the drive to ignore permissions? You could also just copy the folder then delete the original (option control click the trash can then empty it).
     
  3. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
  4. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #4
    Yeah, it is a common problem. The ability to lock files and folders is kind of a hold over from OS 9 and isn't handled very well in OS X. It usually ends up with you having to do sudo rm or something to get rid of it.
     
  5. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #5
    I hate having to empty my Trash on an NFS mounted home directory.

    At least file ghosting isn't much of an issue anymore.
     
  6. ktalebian thread starter macrumors regular

    Joined:
    Dec 25, 2007
    #6
    It's like above 200GB on my external hard drive! I don't have any other place to copy that!
    And no, I only have one user on this Mac.
     
  7. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #7
    So the entire folder is 200gb? Have you checked to see if the computer is ignoring permissions (use get info on the drive)?
     
  8. ktalebian thread starter macrumors regular

    Joined:
    Dec 25, 2007
    #8
    I read somewhere about the ignoring permission, but there is nothing there! I mean I don't have that option under the Get Info menu. Under "Sharing & Permission" it only says that "You can read files" and nothing else!
    thanks
     
  9. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #9
    It only shows up when you get info the external disk, not when you get info anything inside it.
     
  10. Tonerl Guest

    #10
    Unlocking Files and Folders

    I had this problem today (I'm a switcher on his 3rd full day) and discovered an answer (can't remember the URL).

    Open a Terminal session and navigate (using cd to navigate and ls (that's a lowercase L) to see what's there) to the place where you can see the file or directory (folder) that you wish to unlock. Then, enter
    chflags nouchg filename
    or
    chflags -R nouchg foldername

    It worked for me 4 times!

    HTH
     

Share This Page