Unlocking iPhone 3G FW 4.2.1 BB 05.15.04

Discussion in 'Jailbreaks and iOS Hacks' started by sviato, May 9, 2011.

  1. sviato macrumors 68020

    sviato

    Joined:
    Oct 27, 2010
    Location:
    HR 9038 A
    #1
    A girlfriend of mine asked me if it's possible to unlock her iPhone 3G running FW 4.2.1 and BB 05.15.04.

    I googled these figures to see if I can find a way but all I seem to find is articles from November/December '10 which state that you need to update the baseband to the iPad baseband.

    Is there currently any other way to do it? I could probably do the update for her, but I believe she wants to sell the phone and I wouldn't want there to be problems later on (since I've read that you can't downgrade the baseband).

    Any info will be appreciated, thanks.
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    If her Iphone has bootloader 05.08, then download baseband is achievable. Why don't you download tiny umbrella, run it and see what bootloader you have on the phone. If it higher than 05.08, then the only way to unlock it now is to install Ipad baseband.
     
  3. mikeTOOtall macrumors newbie

    Joined:
    May 10, 2011
    #3
    I am in the exact same situation as you, sviato, except it is my sister's phone :) She has FW 4.2.1 and BB 05.15.04 and wants to unlock without compromising the integrity of the phone.

    Would downgrading to 4.1 help at all? I saved the SHSH on my sister's phone before I upgraded it from 4.1 to 4.2.1 (i know, stupid move to upgrade, didn't realize until after I did it), so if I downgrade to 4.1 and restore the SHSH, would that help matters?
     
  4. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #4
    Possible unlock is based on the baseband. And, downgrading the firmware won't downgrade the baseband => possible software unlock. The only exception is if you were lucky enough to have a first few only 3G phone with bootloader 5.08 which has an exploit were you can downgrade the baseband anytime. If it doesn't, the only option is to install the hack iPad 6.15 baseband which have known issues, like GPS not working.
     
  5. mikeTOOtall macrumors newbie

    Joined:
    May 10, 2011
    #5
    I see... in TinyUmbrella it says 05.15.04-5.9_M3S2, so I am assuming that means the bootloader is version 5.9?

    What is the SHSH anyway? I saved it before I upgraded to 4.2.1, that won't help me at all?
     
  6. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #6
    It seems you don't have the bootloader with the exploit that allows you to downgrade the baseband.

    Have saved old SHSH blobs allows you to trick iTunes into allowing you to install old firmware that Apple no longer allows. On 3G phones, Apple started requiring SHSH blobs from 4.0 firmware and above. 3G don't have blobs for 3.1.3 and below so you can install them at anytime.
     
  7. mikeTOOtall macrumors newbie

    Joined:
    May 10, 2011
    #7
    I see... so I guess my only option is to use the iPad baseband. :(

    I've heard this kills the GPS, is this true?
     
  8. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #8
    Yes. GPS not working is one of the known issue.
     

Share This Page