Unlocking iPhone 3GS 4.3.2 for T-Mobile

Discussion in 'Jailbreaks and iOS Hacks' started by iphonenoobie, Aug 8, 2011.

  1. iphonenoobie macrumors newbie

    Joined:
    Aug 8, 2011
    #1
    I bought an iPhone 3GS from someone off craigslist. The iPhone is version 4.3.2 with the modern firmware 05.16.02. It is already jailbroken, but I cannot figure out how to unlock it to use it with T-Mobile. I've been googling "how to videos," and they say I have to upgrade to 06.15.00 with a certain type of jailbreak. How do I do that if my iPhone is already jailbroken? It is getting frustrating and I can't figure out how to do it. Can anyone help me? Thanks.

    P.S. Under my settings, I have a Carrier tab. Does this mean I have already unlocked the phone? I do not have a T-Mobile SIM card to test it out with at the moment.

    P.S.S. I am an iPhone noob, so please explain it so even a 5 year old can understand it :)
     
  2. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #2
    My advice learn about it rather then wanting it so simple a caveman can do it tutorial. besides trusting complete strangers including myself. I would want to learn how and why 100% myself. I would also want to learn the risk of the unlock,. 6.15 you will loose your GPS! 6.15 youwill not be able to take it back to Apple for service in or out of warranty. 6.15 you will always need to wait for updated jb that will allow you to cook the firmware. If they stop making the tools you can not update any further. read all the risk before you do it there is no going back. Iclarified.com has very good tutorials there. oh and google works amazingly well. in the time it took you to create a account and post this you could have found the answers. I know this isn't what you want to here I'm a realist.
     
  3. iphonenoobie thread starter macrumors newbie

    Joined:
    Aug 8, 2011
    #3
    Yes, I've done the research, and I am aware of the risks. But is there another way to unlock an iPhone running 4.3.2 without converting to 6.15? If there is, I would like to know. My problem lies in having an already jailbroke iPhone that is 05.16.02 without the 6.15 that's only obtainable through jailbreaking with the ultrasn0w, I believe. If there's a way to get the 6.15 with my current jailbreak, please let me know. Thanks.
     
  4. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #4
  5. iphonenoobie, Aug 8, 2011
    Last edited: Aug 8, 2011

    iphonenoobie thread starter macrumors newbie

    Joined:
    Aug 8, 2011
    #5
  6. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #6
    There's a 6.15 tutorial on redmondpie, if you look.

    FYI, first run tiny umbrella and save your blobs.
     
  7. iphonenoobie thread starter macrumors newbie

    Joined:
    Aug 8, 2011
    #7
    But those are for iPhones that aren't already jailbroken and running version 4.3.2 and firmware 05.16.02. Almost all the posts are more than a few months ago, and they're telling me to UPgrade to 4.3.2. If the iPhone wasn't jailbroken, then it'd be like the tutorial. I tried to follow through with the tutorial from redmondpie anyways, but after I got to the last step, where you hold Shift and then click the Restore button on iTunes, it said it wasn't possible. I've tried the procedure twice, yielding the same result. I've decided to save the hassle and resell this phone, and buy one that's already unlocked... I wasted 4 hours of my life researching, experimenting, and failing :mad: But thanks for your contribution and your time.
     

Share This Page