Unopened non jailbroken touch will not work

Discussion in 'iPod touch' started by beasley711, Jan 6, 2010.

  1. beasley711 macrumors newbie

    Joined:
    Jan 6, 2010
    #1
    I received a touch over a year ago that I never opened, I had another one. I planned to give this one as a gift at Christmas and wanted to charge the battery, I got the plug symbol. Ended up buying a another one for the gift. I tried to restore the touch didn't work. Tried to recover the touch didn't work, got most of the error messages. I've tried the hold power and wake button and release didn't work. I've tried to downgrade the firmware, upgrade the firmware didn't work. I've tried to downgrade itunes didn't work. I've tried most of the solution on the internet. It is out of warranty from Apple and I would like to try everything I can before I take it in to Apple.

    Can someone please help me.
     
  2. iRawkMac macrumors newbie

    iRawkMac

    Joined:
    Aug 12, 2009
    #2
    To me it doesn't sound like there is much you CAN do. If it's an obvious software problem such as that, I would think the Mac Geniuses should be able to take care of it since it was completely out of your control. They have special tools they use to reset them. They helped me with my old school iPod Mini and replaced it about 9 times because of bad software issues even when it was out of it's warranty. If they don't take it back, replace it, or fix it you can do something crazy and try and jailbreak it through a tethered jailbreak to see if that will spark something in the bricked pod.
     

Share This Page