unreadable m4a from Audio Recorder?

Discussion in 'Digital Audio' started by ExperienceDewey, May 4, 2008.

  1. ExperienceDewey macrumors newbie

    May 4, 2008
    Hi there

    I was using Audio Recorder to record a conversation and it froze as it saved the file. The file is there (as "untitled recording.m4a") but I haven't been able to listen to or convert it. Says "this file is not a movie file" when I try to open it.

    I've tried opening it in VLC, Miro, Quicktime, iTunes and it doesn't read in any of those either.

    It will open in Audacity but only as a tiny burst of static -- the file is 6.5 MB so I know there's more in there than that.

    Does anyone know another application I can try to repair/read it?

  2. beatsme macrumors 65816


    Oct 6, 2005
  3. ExperienceDewey thread starter macrumors newbie

    May 4, 2008
    Garageband doesn't seem to recognize it either.
  4. beatsme macrumors 65816


    Oct 6, 2005
  5. pavinder macrumors member

    Jan 16, 2009
    I have an identical issue. Audio Recorder crashed when saving a 1 hour recording, and I have a 46MB file.
    Audacity opens it with a duration of 4 seconds!
    I tried the Import Raw option, but it asks for whether its big endian or little endian and 8/16/24/32 bits. I have no idea of such things.

    Any suggestions? Its an hour of conversation I won't be able to record again!

    (I tried various other audio programs - QT/iTunes/Peak/WaveEditor) but nothing could import the file.

    I also loaded up Hexfiend and looking at different headers from multiple working files created by the same program, they all have the same general format (i.e. the first 53256 bytes or thereabouts have recognizable similar sections) but much of the data differs by a just few hex characters here and there and I have no idea what means what.

    The corrupted file however has no apparent header, so I tried to copy/paste header information from one of the working m4a files into the corrupt file, but end up with the "fixed" file being seen as the same duration as the working m4a (i.e. only a few seconds in length), whereas the corrupted file is nearly an hour long.

    No idea if pasting in such a way is critical down to the exact byte or whether an approximation might work.

    Any ideas where to go from here?

    Thanks in advance for any advice.
  6. sommeralex macrumors newbie

    Jul 27, 2008
    i have the same problem :-(

    and my file is very important..
  7. jarife macrumors newbie

    Aug 8, 2010
    I am now faced with the same problem.

    Did any of you ever recover the recording?

Share This Page