Unreal Tournament 2004 Graphical Corruption on X3100 IGP Santa Rosa

Discussion in 'MacBook Pro' started by Whitesnake, Dec 3, 2007.

  1. Whitesnake macrumors newbie

    Joined:
    Nov 2, 2007
    #1
    Does anyone have a possible solution for the graphical corruption I'm seeing here? <pictures below>

    My guess is this might have something to do with the bad driver performance Windows Vista users have been experiencing with this IGP.

    I've noticed Quartz Extreme and Core Image have been quite choppy also.

    I'm using the latest UT2004 Patch 3369 with Universal Binary.

    http://img507.imageshack.us/img507/1486/ut2004x3100screen1vs0.jpg
    http://img210.imageshack.us/img210/7154/ut2004x3100screen2it8.jpg
    http://img153.imageshack.us/img153/9813/ut2004x3100screen3cb4.jpg
    http://img153.imageshack.us/img153/5003/ut2004x3100screen4jl1.jpg
     
  2. anotherarunan macrumors 6502

    Joined:
    Sep 18, 2007
    Location:
    London, United Kingdom (UK)
    #2
    looks fine to me :confused: whats wrong? am i just being
    blind here?
     
  3. masse macrumors 6502a

    masse

    Joined:
    May 4, 2007
    Location:
    MA/GA
    #3
    Does it happen all of the time? It almost looks like something with a refresh rate. Are other games okay?

    PS what kind of fps are you getting?
     
  4. Whitesnake thread starter macrumors newbie

    Joined:
    Nov 2, 2007
    #4
    This problem happens all the time and is constant when running in a Window or Fullscreen mode.

    I haven't measured the frame-rate but it could be a lot better from what I can see.

    I've neither experienced any graphical bugs in any other game I've tried, just a slow frame-rate that makes you wish it was a GMA950. ;)
     
  5. feyn-man macrumors regular

    Joined:
    Oct 24, 2007
    #5
    ;) me too
    I can't find anything wrong from these picture.
     
  6. Whitesnake thread starter macrumors newbie

    Joined:
    Nov 2, 2007
    #6
    Look at the weapons and vehicles the textures are missing or being displayed wrong.
     
  7. Celeron macrumors 6502a

    Joined:
    Mar 11, 2004
    #7
    Looks like a driver problem to me. How hot is the macbook?
     
  8. themachatter macrumors newbie

    Joined:
    Nov 11, 2007
    #8
    I had a similar problem when playing this in OSX. I had the Windows version from before, and playing it through bootcamp the game runs beautifully with no graphical problems like the ones shown.
     
  9. Whitesnake thread starter macrumors newbie

    Joined:
    Nov 2, 2007
    #9
    I haven't measured the temperature of the MacBook yet, but as with all intensive applications it makes the fan go pretty fast.

    What monitoring application would you recommend?

    Just to add, Doom 3 has also displayed some graphical anomolies here and there and also no sound.
     

Share This Page