Unreal Tournament 2004 Install Crash (Leopard)

Discussion in 'Mac and PC Games' started by IceflowStudios, Oct 29, 2007.

  1. IceflowStudios macrumors newbie

    Joined:
    Sep 11, 2007
    #1
    Hey all. I'm having issues with UT2k4 on Leopard. It worked fine on Tiger, but when I went to install it on Leopard, I'm getting the error "Unexpected data in installation file" about 80% into the installation. I can't continue the install.

    Anyone have a solution for this?

    Thanks.
     
  2. Luap macrumors 65816

    Luap

    Joined:
    Jul 5, 2004
    #2
    Do you still have your Tiger install? With UT? (From an archive & Install perhaps) If so, just move the main UT components/folder's over to the same locations in Leopard. There are 2 things to move.. The App package itself, and the UT2004 folder from your users > application support folder.

    I've not tried to install it in Leopard. But I do know that it runs fine in Leopard (Freezing on latest iMacs excepted).
    I did a Leopard upgrade install from Tiger, and UT2004 made it through fine, so I had no need to reinstall it.

    I cant think why it wouldn't just install in Leopard however..
     
  3. IceflowStudios thread starter macrumors newbie

    Joined:
    Sep 11, 2007
    #3
    Unfortunately, I don't have the Tiger install. I clean installed Leopard when I got it.
     
  4. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #4
  5. IceflowStudios thread starter macrumors newbie

    Joined:
    Sep 11, 2007
    #5
    Yup. I used that. I'll try it again and take a note at which file the install stops at.
     
  6. IceflowStudios thread starter macrumors newbie

    Joined:
    Sep 11, 2007
    #6
    Well, I just ran the install a few times and it crashes at different files. I have no clue. :(
     
  7. IceflowStudios thread starter macrumors newbie

    Joined:
    Sep 11, 2007
    #7
    Last update. Seems that the file intro_jugchick.ukx seems to be the file of choice for the crash.
     
  8. hankolerd macrumors 6502

    hankolerd

    Joined:
    Sep 19, 2007
    Location:
    Seattle, WA
    #8
    I wish I had it to try. If you know of anyone else with install discs you might try theirs to be sure yours are not scratched or something. The fact that it crashes at different spots makes it sound like it MAY not be the OS's fault.:apple:
     
  9. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #9
    When I get my Leopard DVD and if I can find my UT2004 install DVD, I'll test it out to see if it works.

    It *is* possible to do a manual install however.
    You download the demo, then you manually extract (not just copy but uncompress) all the files off the DVD into the demo .app package. Then you download the 3369.2 patch and patch the demo.

    There are more detailed instructions out there but that is the jist of it. This is the same method as using a Windows UT2004 install CD/DVD on a Mac.
     
  10. jhaskins75 macrumors newbie

    Joined:
    Nov 4, 2007
    #10
    I've noticed this as well in leopard. If you do an install of UT2k4 then after a while go an fix permissions within disk utility UT2k4 won't even launch, it will say "An unexpected Error has occurred". I noticed this a short while after I ran a permissions fix on my drive.

    I removed the corrupted application from my hard drive, and restored it with a version in Time Machine that was backed up prior to the permissions correction... Works like a charm now.

    Hope this helps with other games as well, if someone runs into launch errors after doing a permissions fix in Leopard. It's a bit annoying that I had to find this out, however, now knowing this will help troubleshoot other launch errors due to permissions.

    In short.. Don't fix your drive permissions unless something is majorly pooched, if you do, BACKUP BACKUP BACKUP.
     
  11. marioman38 macrumors 6502a

    marioman38

    Joined:
    Aug 8, 2006
    Location:
    Elk Grove, CA
    #11
    Hmm, i installed UT2k4 last night w/o any issues. Clean Leopard install from last week.

    I used the updated installer with the DVD in the drive.

    Installed to apps folder, then updated to v. 3369 before playing. Everything is working fine.

    I'm thinking you have a scratched disc?? Leopard doesn't seem to causing any problems w/ UT 2004.
     
  12. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #12
    Marioman - that's on your MacBook Pro?

    I can't get UT2004 (which was fine in Tiger) to launch at all after upgrading my Intel Mac to Leopard. (Nor can I do a fresh install: I get an error partway through--I think I DO have a scratched disc.) But I CAN wipe out my old Application Support stuff. Doesn't help.

    I did Repair Permissions though--maybe that's why I can't play. If I can confirm that anyone is able to play UT2004 on INTEL in Leopard (I know PPC is OK) then that's a good sign.
     
  13. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #13
    BTW, the error I get in the Mac console upon trying to launch UT2004 is:

    "dyld: Library not loaded: @executable_path/libSDL-1.2.0.dylib"

    Is that what the permissions-repair thing causes?

    (This other thread suggests permissions repair may be broken in Leopard: http://forums.macrumors.com/showthread.php?t=375608 )
     
  14. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
  15. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #15
    I have the same problem. It worked fine in Tiger on my Mac Pro. I just installed it again and it won't launch at all (updated fully to 3369.2).

    This is was the console says:
    Code:
    12/30/07 1:17:15 PM Unreal Tournament 2004[2190] Warning once: This application, or a library it uses, is using NSQuickDrawView, which has been deprecated. Apps should cease use of QuickDraw and move to Quartz. 
    12/30/07 1:17:18 PM [0x0-0x112112].com.epicgames.ut2004[2190] Assertion failed: InPos<=Size [File:../../Core/Inc/FFileManagerUnix.h] [Line: 187] 
    12/30/07 1:17:18 PM [0x0-0x112112].com.epicgames.ut2004[2190] History:  
    12/30/07 1:17:18 PM [0x0-0x112112].com.epicgames.ut2004[2190] Exiting due to error 
    12/30/07 1:17:18 PM com.apple.launchd[104] ([0x0-0x112112].com.epicgames.ut2004[2190]) Exited with exit code: 1
    (also, I checked, it's not any permissions error)
     
  16. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #16
    FWIW, after the above fix, I have had many trouble-free hours of UT2004 in Leopard on Intel. There's some (very) occasional odd behavior and a few unexpected-quits. But no more often than in Tiger--just different.

    (And I can't get UnWheel to launch.)
     
  17. aurezio macrumors newbie

    Joined:
    Mar 17, 2008
    Location:
    Rome, Italy
    #17
    Hi there, I'm new to this forum. I surfed across here 'cause I have the same "Unexpected data in installation file!" error. My installation seems to stop always at intro_nikoli.ukx file. I really don't know what to do. I'm even new to the mac world :)

    Any help would be appreciated.

    Aurezio (running Leopard)
     
  18. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #18
    That doesn't sound like a standard file.

    I'd try, in this order:

    1. The updated installer http://www.destineerstudios.com/support/ut2k4.html (And then don't forget the latest patch from MacGameFiles.com.)

    2. Updating Leopard fully via Apple > Software Update and then running Repair Permissions.

    3. Running YASU, found at versiontracker.com.

    Good luck!
     
  19. aurezio macrumors newbie

    Joined:
    Mar 17, 2008
    Location:
    Rome, Italy
  20. ADDABAD macrumors newbie

    Joined:
    Dec 23, 2006
    #20
    I Cannot Install

    HELLO,
    MY NAME IS ADAM ROGERS. AND I OWN UNREAL TOURNAMENT 2004. AND HERE IS MY PROBLEM. I CANNOT INSTALL IT ON MY IBOOK G4. IT IS A MEMORY ISSUE. SO I BOUGHT AN EXTERNAL HARD DRIVE. SO NOW I HAVE PLENTY OF MEMORY. BUT IT STILL WILL NOT INSTALL. IT GETS READY TO, BUT WHEN THE LOAD WINDOW APPEARS IT IS TOO SMALL. THE INSTALL BUTTON DOES NOT SHOW. IT IS CUT OFF. ANY ADVICE OR TIPS?

    ADDABAD@AOL.COM
     
  21. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #21
    That's weird. Maybe try hitting Return or Enter to trigger the invisible button.

    And make sure you have the updated installer at the link above.

    (Is your iBook set to some really small screen size? Set it to 1024x768 if so.)
     
  22. Wotan31 macrumors 6502

    Joined:
    Jun 5, 2008
    #22
    I just bought UT2004 so my install disc is a factory sealed brand new one. I have a fully updated MBP 2.33 Ghz running 10.5.5. I was getting the random installer problems (yes, using the updated installer) where it would fail on different files each time you run it.

    My "fix" was just to keep running it over and over until eventually it completed successfully. Not much of a fix really, but it worked. Poor quality disc I suspect? I dunno.
     
  23. wrecklessmonkey macrumors newbie

    Joined:
    Mar 9, 2009
    #23
    I have just installed leopard on my imac G5 and when I go to install UT2K4, after entering the cd key, it quits and asks if I want to relaunch.

    Where do you get the updated installer that I keep hearing about?

    I have already downloaded the patch for after I install it
     
  24. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #24
    It's on the official MacSoft site. Scroll down here:
    http://www.destineerstudios.com/support/ut2k4.html
     
  25. fredsarran macrumors 6502

    fredsarran

    Joined:
    Jun 15, 2008
    #25
    I have the solution for you : In the installer package on the CD "Unreal Tournament 2004 Installer", you have this file "Animations.tar", and in this file, you have a second folder with files that should not be there. "Animations" should be the only folder.

    First, give "Unreal Tournament 2004 Installer" all read/write permissions, copy "Animations.tar" to your hard drive, extract it and remove the second unwanted folder. Recompress it with .tar extension and put it back in "Unreal Tournament 2004 Installer" by overwriting the other one.

    Launch install with updated installer if needed, and it should be fine :)

    Needing help, just PM me.
     

Share This Page