unreal tournament 2004 on Macbook Pro problem

Discussion in 'Mac and PC Games' started by :rug:dude, Jan 4, 2008.

  1. :rug:dude macrumors newbie

    Joined:
    Dec 13, 2007
    #1
    hello guys

    I installed unreal tournament 2004 on my Macbook Pro running 10.4.11 and the game felt horrible. It had a lot of scaling even with the graphics set to lowest.
    After looking into the settings it had OpenGl for a render device and nothing else to choose. So i guess that means it's not recognizing my gfx card?
    The game had its latest patch (3369) installed from the start so i didn't update or patch anything. any ideas?

    P.s. I m fairly new to mac environment so maybe its something really simple.

    Thanks

    Specs: 2.4 GHz Intel core 2 duo 2 GB ram
     
  2. xparaparafreakx macrumors 65816

    Joined:
    Jul 29, 2005
  3. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #3
    Do you mean scaling as in an incorrect screen resolution? If you press ~ to open the console in game, you can type this:

    setres 1440x900x32

    This will set the resolution to that which is the native 15 inch screen resolution.

    There is probably nothing wrong with your graphics card, and OpenGL is the only option on Mac games. Also, make certain that the patch you installed is 3369.2, which has the universal update.

    Could you be a little more clear with what you mean by scaling?

    Edit: Just a little side note. The MBP is perfectly capable of running the game at 1440x900 at maximum settings (I have the 2.2 ghz model with half the vram), so if you are having framerate issues it could be because the game isn't patched up to the universal binary, or something is wrong somewhere else.
     
  4. :rug:dude thread starter macrumors newbie

    Joined:
    Dec 13, 2007
    #4
    hey guys here I m again. i ddnt reply for some time since i upgraded to leopart and i didnt install the game until recently.
    So i downloaded the 3369.2 and i installed it. nothing significant since the game feels choppy (thats what i meant when i said scaling, :p)
    another thing i didnt mention is my 5400 rpm hard disk. could it be that?
    and another thing. where do i find the utcomp mutator for mac?

    thanks
     
  5. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #5
    UT mutators are OS independent, so there is no Mac-specific version. You can just download the normal UTComp mutator.

    Are you certain nothing is running in the background taking up CPU% or is some other program hogging the video card? Beyond that I don't know what could be making your gameplay choppy. It should be extremely fluid with a nice high fps on that machine.

    Only difference the HD speed will make is level load time, won't affect FPS.

    Edit: I'm also still unsure exactly what you mean by choppy. First thing I think of is low frame rate but I can also think of other things it could mean.
     
  6. :rug:dude thread starter macrumors newbie

    Joined:
    Dec 13, 2007
    #6
    thanks for your replies guys

    yeah i m pretty sure nothing else is running. i also checked the energy save setting and it's on best performance.
    how can i else describe choppy... you could all it low fps but even when i had like 100 at some point in it still felt... emmm choppy:p
    i forced the refresh rate from 60 to 100 but nothing major happened so i dont know what else to do.
     
  7. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #7
    hmm one thing I'm thinking is you may mean the screen is 'tearing'. Hard to really describe it, but here are two pictures showing it.

    http://www.macintouch.com/reviews/macpro/macpro_pics/tearing-halo-1.jpg
    http://www.richleader.com/images/Pulse/bargainbin/bargain_bin_review/tearing.jpg

    If you notice in the shots, there are sections of the screen that are misaligned, or 'torn', this due to the framerate not matching the refresh rate. Only way to fix that is by turning VSync on, but the option in UT2004 doesn't do anything. If you had an ATI card, you could just use ATI's display controls to force VSync on... but there is no such thing for Nvidia users on the Mac.

    I've searched high and low for a way to force vsync on for Nvidia cards on the Mac and never found a thing.
     
  8. :rug:dude thread starter macrumors newbie

    Joined:
    Dec 13, 2007
    #8
    that seems to be it man. i havent tried VSync but as you said it doesn't do anything.
    so theres nothng to do!?

    thank you man - you saved me from a lot of pointless searching.
    if i install windows would i have the same problem? because its hardware issue? not that i miss xp of course but for ut! anything!:p
     
  9. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #9
    It's a software issue, with two sources to blame and sadly there is nothing you can do on the Mac side of things (besides get a Mac with an ATI card).

    Apple isn't suppling Mac users with an Nvidia control panel that could allow us to force certain things on, like Vsync. If our MBPs had ATI cards we could use ATI Displays and do this.

    So if you use bootcamp, you can use Nvidia's control center to force vsync on and other things and there will be no more screen tearing once you get it on.

    The other problem is that UT2004 doesn't properly enable VSync itself; however a control panel like ATI Displays can override it. The setting in UT2004.ini is there, but it doesn't do anything. Setting "UseVSync=True" under the OpenGLDrv.OpenGLRenderDevice section in the UT2004.ini does squat.

    So you can blame Apple for not giving us a Nvidia control center, or blame Epic games for not making the in-game VSync setting work.
     

Share This Page