unregistering a phone number from iMessage

Discussion in 'iOS 6' started by bigchrisfgb, Sep 25, 2012.

  1. bigchrisfgb, Sep 25, 2012
    Last edited: Sep 25, 2012

    bigchrisfgb macrumors 65816

    Joined:
    Jan 24, 2010
    #1
    So I got my iPhone 5, when I did I got it from another provider and backed up all the data from my iPhone 4. Because of this the iPhone 5 came with it's own number however I'm currently in the process of getting my number transferred to my new provider for my iPhone.

    My iPhone 5 now though has 2 phone numbers it receives iMessages off, I want to delete the phone number my iPhone 5 came with but it won't let me (it's shaded out and won't let me un click it).

    To make matters worse on my iTunes account I don't have any mobile numbers listed so I can't do it from there either.

    So any ideas?, I don't want to use the new number I have been given and I don't want to get iMessages from random people once the number has been reassigned to someone else.

    I have been able unclick on that number for my Macbook Pro, but on both my iPhone 4 and iPhone 5 I cannot delete that number from receiving iMessages.
     
  2. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #2
    Once your Port Request completes, the "new" number should completely disappear from the phone.

    If iMessage somehow retains it (not sure about this because I worked on the carrier side) then I'm not sure what to do. Probably a full Erase All Content And Settings to start fresh with your "old" ported number.
     
  3. bigchrisfgb thread starter macrumors 65816

    Joined:
    Jan 24, 2010
    #3
    Thanks.

    Also my iPhone 4 is being sold, so I'm right just erasing it and then starting it up again (without my sim card in) will make it so nothing to me is related on that phone?
     
  4. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #4
    Correct. Erase All Content and Settings makes it a "brand new' phone basically.
     
  5. sb22 macrumors 6502

    sb22

    Joined:
    Aug 14, 2012
    #5
    I encountered this after porting too. You will need to manually change your number in General > Phone> your number
     
  6. bigchrisfgb thread starter macrumors 65816

    Joined:
    Jan 24, 2010
  7. thewitt macrumors 68020

    thewitt

    Joined:
    Sep 13, 2011
    #7
    Try disabling iMessage and then enabling it again.
     
  8. boabmatic macrumors member

    boabmatic

    Joined:
    Oct 13, 2011
    Location:
    scotland

Share This Page