Unresponsive keyboard and mouse for 8 min after boot

Discussion in 'Mac OS X Lion (10.7)' started by dancook99, Feb 18, 2012.

  1. dancook99 macrumors member

    Joined:
    Aug 12, 2011
    #1
    Hello everyone,

    iMac 2011 with Lion 10.7, just upgraded from 10.7.2 to 10.7.3

    Issue: it takes about 8 minutes for the keyboard to be responsive after a boot. Batteries are fresh and keyboard is connected. I had automatic logon disabled and as soon as login screen was showing, typed my username <tab> password <enter>. It took 8 minutes for Lion to log me in.

    I then enabled automatic login, it logs me in and shows the desktop but keyboard is still in La-La land for about 5-8 minutes. Mouse is semi-working, pointer moves but clicking anything is "paused" for the same amount of time.

    Anyone experiencing this issue? Waiting 8 freakin' minutes to be able to do something is rather annoying.

    Issue is present in 10.7.2 and 10.7.3
     
  2. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #2
    Do you have a lot of Apps that want to restore their state upon reboot?
    That process can take minutes, and can involve funky keyboard/mouse behavior.
    Try unchecking the "restore App state upon restart" box before you shut down.
     
  3. dancook99 thread starter macrumors member

    Joined:
    Aug 12, 2011
    #3
    Thanks but it didn't help. I've removed all login items and behavior is the same.

    But like I wrote in my original post, if automatic login is disabled, then there is no one logged in, so no apps are started/pending to start. Still it takes 8 minutes to act on my keyboard inputs.
     
  4. dancook99 thread starter macrumors member

    Joined:
    Aug 12, 2011
  5. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #5
  6. dancook99 thread starter macrumors member

    Joined:
    Aug 12, 2011
    #6
    done SMC reset. Issue not resolved

    done PRAM reset. Issue not resolved
     
  7. dancook99 thread starter macrumors member

    Joined:
    Aug 12, 2011
    #7
    @Partron22: thanks for your reply.

    Normally, iMac is wired no WiFi.

    Tried unplug wire, no WiFi: not better
    Tried no wire, WiFi on: not better
     
  8. bdodds1985 macrumors 6502a

    bdodds1985

    Joined:
    Jul 18, 2011
    Location:
    Tartarus
    #8
    bluetooth mouse? what kind of mouse and keyboard?

    try uninstalling whatever you have and reinstalling, or if it is bluetooth, remove the device and add it again.

    if that does not work, I would roll back and install combo updates instead of using system update. maybe one update at a time.
     
  9. fhall1 macrumors 68040

    fhall1

    Joined:
    Dec 18, 2007
    Location:
    (Central) NY State of mind
    #9
    Try wired USB mouse and keyboard to see if it makes any difference.
     
  10. dancook99 thread starter macrumors member

    Joined:
    Aug 12, 2011
    #10
    Apple wireless keyboard and magic mouse that comes with the iMac.

    I've decided that I will live with it. It only happens at boot time. Afterwards, I'm good. A fresh install is not an option at the moment.

    Thanks everyone who replied.
     
  11. nerfjames macrumors newbie

    Joined:
    Aug 29, 2007
    #11
    Same Problem

    This problem started for me today.

    I have tried both wired mouse and wireless. Same issue.

    Shortly before this problem began, I installed the "Unity Media Player" plugin for Safari. It was so my child could play games on some website.

    I have since uninstalled the plugin, but my symptoms continue.

    I suppose the problem could have started a long time ago, as I hardly ever have a need to reboot.

    MacMini C2D. 10.8.1
    I can Remote Desktop into the machine sometimes while it's in this state, and remote keyboard/mouse work fine.

    strange.
     
  12. preppyr6 macrumors newbie

    Joined:
    Sep 9, 2011
    #12
    This problem started for me today after updating 10.8.2 (software update released today). Mac Mini (2011) with SSD completed update but would not shut down (gray wheel). Forced shut down, and now it takes several minutes to boot to login screen (used to take a few seconds). Keyboard and mouse are unresponsive for 8-10 minutes. Tried recovery disk, no luck. Same problem with keyboard and mouse. Wiped SSD and tried to reinstall from USB drive. Mouse cursor worked but was stuck on color balloon for 8-10 minutes, clicking did nothing. Reinstalled 10.8 and updated to 10.8.2. Same problem persists. Checked on my secondary HDD (running 10.7.3), and had same problem with super-long startup and no mouse/keyboard function.

    I ran a hardware test, and nothing came up as a problem. Reset NVRAM, no luck. Reset SMC, no luck. I'm out of ideas. Going to apple store tomorrow.


    Edit: both mouse and keyboard are WIRED
     
  13. mathieu243 macrumors newbie

    Joined:
    Nov 11, 2012
    #13
    Something hang on boot = mouse and keyboard unresponsive for a while

    I had this problem since few month and fix it lately by doing a lot of change at once, so I can't really tell you what was the exact cause but it's something related with those changes...


    • Put your computer in auto login
    • Remove everything that start on boot
      a lot of app were starting up automatically (mail, ps3 media player, skype, itunes helper, air media server)
    • disable Bluetooth and use usb keyboard and mouse... your computer may searching a Bluetooth device on boot and waiting for pairing, or a Bluetooth device is not working properly and computer wait for him to respond.
    • remove all unnecessary usb device except keyboard and mouse.


    Also try to enable screen sharing and use a vnc client (on another computer, ipad or iPhone) instead of usb mouse and keyboard while the're not responding to see if the computer react normally to remote control and not reacting on usb device.

    Hope this helps ;)


    Mathieu
    MacMini 2009
    core 2 duo 2Ghz
    4 gig ram
    Snow Leopard 10.6.8
     
  14. mark-in-seattle macrumors newbie

    mark-in-seattle

    Joined:
    Oct 10, 2010
    Location:
    Seattle, Washington, USA, Pacific NW
    #14
    Fixed - Keyboard Mouse 8 min Delay after boot

    For others looking for solutions to delayed OSX desktop responsiveness on the keyboard and mouse. This post by Christopher Parsons ( http://www.christopher-parsons.com/blog/technology/solved-bluetooth-devices-not-connecting-to-osx/ ) corrected our situation.

    His Solution:

    Delete com.apple.Bluetooth.plist. This file is found at HD/Library/Preferences.
    Turn off Bluetooth on your Mac. This is done by clicking the Bluetooth icon in the menu bar and selecting ‘Turn Bluetooth Off’.
    Unplug input-based USB devices (e.g. any USB mice, keyboards, Wacom tablets, etc).
    Shut down computer. Do *not* restart, but do a full shut down.
    Turn off your Bluetooth devices. (we removed trackpad batteries)
    Boot computer. (used wired mouse)
    Turn Bluetooth on. (restored trackpad batteries - MacOSX recognized new device and asked to pair with it ..etc)
    Begin pairing devices. This involves clicking: Bluetooth icon in menu bar >> Set up Bluetooth Device >> Select Bluetooth device >> Follow on-screen instructions. In the case of your keyboard, I would suggest pressing the ‘Enter/Return’ button several times after entering the passphrase shown on your screen.

    This should result in your devices being reconnected.

    /****** end of Christopher's Solution *******/

    My wife’s new 2013 iMac with OSX Mt Lion started taking many minutes to boot to the desktop but once there for an additional 5 to 8 minutes both the keyboard and mouse were locked and non-responsive. This occurred even when bluetooth keyboard and mouse were replaced with wired versions. Very strange and frustrating. Our own troubleshooting and a call to Apple Care could not resolve the problem. I noticed in the system.log file references to “KCGErrorInvalidConnection… with cryptic references to bluetooth, which lead us to Christopher’s post. Following his procedure and reestablishing the iMac’s link to the bluetooth track pad and keyboard cleared both our slow boot and input device issues. System works fine now with wired or wireless input devices.
     
  15. FrankySavvy macrumors 65816

    Joined:
    Mar 4, 2010
    Location:
    Long Island, NY
    #15
    iMac 21" 2011 with Mountain Lion 10.8.5 was having this issue. Mouse and Keyboard would be unresponsive for about 5 minutes after restarting or booting up fresh.

    Tried everything listed in this forum. Nothing was working. I decided to pull all connections to the mac.

    It turns out it was the Firewire 800 Cable connection I had between two computers causing the delay. Disconnecting that cable and everything loads up fine now.

    Hope this helps someone else!
     
  16. glenesis macrumors newbie

    Joined:
    Mar 13, 2014
    Location:
    New York
    #16
    Same Problem

    I've had the same problem on two Hackintoshes running 10.8.2 and up to 10.9.2 (currently) and I have not found a fix. However, once booted, I just discovered that if I unplug BOTH my keyboard (an i-rocks Mac extended wired USB keyboard) and my mouse (a Logitech wired USB mouse), and plug them in again, I don't have to wait for the five to ten minutes for my mouse to free up.

    If I leave the keyboard and the mouse plugged in at boot, I see this in my console:

    3/13/14 2:35:34.000 AM kernel[0]: USBF: 5.111 The IOUSBFamily was not able to enumerate a device.

    This also appears a bunch of times if I boot the machines in verbose mode.

    I have read in another forum that for some folks, this problem began with Lion, but I skipped over Lion; I was not a fan.

    I have also noted that when I boot with no USB devices plugged in, I can have instant access to my keyboard and mouse if I plug them in after the desktop loads up.

    That is my story. I hope this works for all of you. If I find a solution, I promise that I will post it.

    I joined your community today, after years off lurking. I'm glad to be a part.

    Cheers!
     
  17. dancook99 thread starter macrumors member

    Joined:
    Aug 12, 2011
    #17
    Thanks everyone !

    for posting your resolutions. At least, other people having the same behavior will find answers here.


    Daniel
     
  18. slehman805 macrumors newbie

    Joined:
    Oct 8, 2009
    #18
    I'm having this issue on an older Mac Pro using an Apple Wired USB Mouse and Keyboard. I've also noticed that the same issue occures when I startup my Mac with Windows 7 setup with Bootcamp. So I am tempted to say it is NOT an OS issue but could be something with the pRam or...?

    Has anyone found a fix for this issue?
     

Share This Page