Unsolicited spontaneous swiping on MacBook Pro retina

Discussion in 'MacBook Pro' started by jmb1273, Nov 20, 2012.

  1. jmb1273 macrumors newbie

    Joined:
    Nov 20, 2012
    #1
    I have a 2 week old 13 inch MBP retina (256GB, 8GB ram, 2.5GHz Intel Core i5, Graphics Intel HD Graphics 4000 768 MB, OSX 10.8.2) which was working fine until a few days ago. When using any application in full screen mode, it spontaneously swipes itself back to the blank desktop "space" after less than a minute. It previously worked as expected in full screen mode, and currently works fine when viewing applications without the full screen mode engaged. Then, today it started displaying my log-in screen with inverted colors (color negative). The colors revert to normal immediately after logging in. This all initially started after accidentally clicking the airplay icon on the MBP while my apple TV was off, and then exiting airplay mode...which may be unrelated. Ctrl-Opt-Command-8 on the login screen temporarily solves the color inversion part of the problem.
    Any ideas? I have tried rebooting, and I even tried Shift-Control-Option-Power while plugged in with the power off (SMC RESET?)
     
  2. jmb1273 thread starter macrumors newbie

    Joined:
    Nov 20, 2012
    #2
    any help out there?

    this is a very annoying issue. anybody know how to fix it? anybody else having the same problem?
     
  3. Raunien macrumors 6502

    Joined:
    Aug 3, 2011
    #3
    If the reset didn't work, I would try to restore to factory settings (reinstall OS) and see if it still behaves that way without any third-party applications.

    Then install your applications and see if the problem pops up. If it does, then it means it's one of your applications that is causing it.
     
  4. jmb1273 thread starter macrumors newbie

    Joined:
    Nov 20, 2012
    #4
    i will try. thanks.
     
  5. jmb1273 thread starter macrumors newbie

    Joined:
    Nov 20, 2012
    #5
    So I reinstalled the OS, but all my same programs were there and the auto-swiping problem was still happening. I then erased the HD and reinstalled the OS from scratch. This solved the swiping problem, and I have reinstalled almost everything I had on it previously without recreating the problem. If it pops up again I'll update the thread. Thanks.
     

Share This Page