iPhone Unsolvable bootloop and error 21 issue. Please help

Discussion in 'Jailbreaks and iOS Hacks' started by howa90, Nov 16, 2014.

  1. howa90 macrumors newbie

    Joined:
    Nov 16, 2014
    #1
    Hi to all,

    Traded in my 4s for a second hand 5 with a "battery issue". Replaced battery and charging port assembly and phone will still only react when plugged in at mains or usb but is stuck in bootloop. It can be discovered in itunes when in DFU, any attempts to restore just lead to error 21.

    Hours of trawling through forums leads me to believe this can be caused by an infected file from jailbreaking? I think I have exhausted all of the obvious solutions - hard reset, holding volume up etc... I have also tried to access files using iexplorer and ifunbox but neither program will recognize that a device is connected. I have been advised elsewhere to try downloading pangu or evasion and rejailbreaking - I have tried both but to no avail as neither program will find the device connected.

    Is there something obvious I haven't tried? It's incredibly frustrating. Thanks in advance for any help!
     
  2. DigitalDawn macrumors regular

    Joined:
    Sep 3, 2011
    #2
    I had the same problem when using passcodes and the latest JB. I read somewhere that doing the jailbreak *after* the restore and sync would solve the problem.

    I tried that, and it seems to have worked.
     
  3. Syndicate0017 macrumors 6502

    Joined:
    May 3, 2013
    #3
    An infected file from jail breaking? Highly unlikely. I saw that forum response you are referring to on apple discussions, and let me just say that person has no idea what they're talking about in regards to a JB and they are misquoting and misrepresenting Apple's words.

    A few things I'd try would be to replace the cable, try a new USB port, and verify your hosts file is correct. The iPads I had to restore at work with error 21 usually ended up being cable or charging assembly related. Since you've already replaced the assembly, hopefully it's just the cable.
     
  4. howa90 thread starter macrumors newbie

    Joined:
    Nov 16, 2014
    #4
    Thank you for your responses.
    DigitalDawn im not entirely sure what you mean but I cannot jailbreak after a restore and sync as itunes will not let me restore...

    Syndicate: My apologies, I didnt mean an infected file, I mean an infected/corrupt app that has been installed that causes the bootloop. I've seen this talked about quite frequently, could this be the case?
    I have tried changing the cable, using a different computer altogether, and I have checked the hosts file - although Im still not 100% sure what it should read?

    Thanks again
     

Share This Page