Unusable slow macbook pro 13" mid 2012

Discussion in 'MacBook Pro' started by imperi, Dec 7, 2014.

  1. imperi macrumors newbie

    Joined:
    Dec 7, 2014
    #1
    Hi guys,

    I hoped someone can help that once had the same problem. I have a mid 2012 Macbook pro 13" standard setup. So 4gb ram, 500 gb hdd etc.

    A few weeks ago, without any reason my macbook started running extremely slow. Unusable slow, with the rainbow icon being permanently there.

    First I thought that it was a faulty hd. Though the hd seems fine, ran Smart utility and everything was okay and booting the macbook using the same hdd but only externally, it ran fine. Pram and SMC reset did not help. Filevault is turned off. Also formatted the hdd and clean installed Yosemite. Nothing worked.

    I was hoping someone has any idea what the problem could be. Thinking it must be the logic board, but could that be the problem of a macbook slowing down? Or maybe it could be a faulty hd cable, though I read an article that stated that a faulty hd cannot be the reason of slowing down. It works or it does not, with speed not being a variable that could change because of this cable.

    Already checked the costs of a new logic board, that would be 700 euro and that simply is not worth the hassle.

    Any Thoughts on what to do? Will be appreciated!
     
  2. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #2
    Sounds like a dead HDD. Since you've clean-installed OS X, but to no avail, you might as well go buy an SSD.
     
  3. 556fmjoe macrumors 65816

    556fmjoe

    Joined:
    Apr 19, 2014
    #3
    He said that he booted the same HDD externally and it ran fine. My guess is the cable.
     
  4. imperi thread starter macrumors newbie

    Joined:
    Dec 7, 2014
    #4
    Thanks for replying. Indeed I already tested my harddrive externally. Is it possible that because of a faulty hddcable my mac slows down, can the cable influence the speed?
     
  5. meson macrumors regular

    Joined:
    Apr 29, 2014
    #5
    It's possible. If enough of the insulation wears off that it can short to the aluminum casing on the computer, then you have a situation where some data makes it though okay and other data fails. You can find the cables pretty cheap, and they are not hard to replace. If it works, great, and if not you aren't out a lot.

    It's certainly worth a try before giving up on the machine. I tend to agree that at the current price of a logic board replacement, I would go ahead and replace the whole machine if it takes more than a new drive or cable.

    Good luck!
     
  6. imperi thread starter macrumors newbie

    Joined:
    Dec 7, 2014
    #6
    Thank you! Going to replace the cable and then we'll see what happens. Hopefully it'll work otherwise one way trip to the bin I guess.
     
  7. sovereign macrumors 6502

    sovereign

    Joined:
    Feb 13, 2009
    #7
    I have had to replace the cable twice on my 2009 MBP. I would bet that this is it.
     
  8. stynger007 macrumors newbie

    stynger007

    Joined:
    Jan 10, 2014
    Location:
    Ontario Canada
    #8
    Hi , just went through this with a mid 2012 Macbook pro a1278- Ran the Activity Monitor and had a misbehaving kernel sucking up 322% of CPU power.

    Next , I found the Mac Identifier in about this mac, Mine is 9,2 and located a directory it was supposedly in , in Library>System>Extensions .. look for ioplatformpluginfamily.kext - right click, choose show package contents. Go to plugins, Enter contents, go to plugins, right click on ACPI_SMC_PLATFORMPLUGIN.kext , choose show package contents. Go in resources, find identifier of your Mac (in my case 9,2) . I got this far, and realized there was no matching identifier in this folder- it went up to 8,3 and 9,2 was nowhere to be found.

    Deleted entire directory contents with no change. Next ,
    Tried terminal with a sudo command of

    sudo mv/System/Library/Extensions/AppleSMCLMU.kext ~

    This supposedly deactivates misbehaving Kernel related to power issues, including throttling of the CPU. This command did indeed move the file, but did not solve my problem.

    Last but not least what worked for me was unplugging the battery from the logic board and removing magsafe power, held power button for 10 seconds, reconnected magsafe whilst holding power button for another 10 seconds, then reconnected battery held power button for yet another 10 seconds, released power button and pressed power- it didn`t take the first time, but did on the second attempt.

    If any of these help post back what worked for you , if anything. Best of luck , Pete
     
  9. imperi thread starter macrumors newbie

    Joined:
    Dec 7, 2014

Share This Page