Unusual behavior when waking up MBA

Discussion in 'MacBook Air' started by TheJing, Jan 7, 2012.

  1. TheJing macrumors 6502a

    TheJing

    Joined:
    Jun 13, 2011
    Location:
    Somewhere in Europe
    #1
    One out of 10 times, when I wake up my MBA it will go crazy and heat up to 90-100C without me doing anything at all.

    Once I realize it's getting very hot for no reason, I close the lid, let it sleep for literally one second and wake it up. After that, it will take a few seconds before the temp is down to 80C, few more seconds and it's back to normal.
    But the thing is, there is nothing going on according to the Activity Monitor. I can be at 98% idle and it will still heat up like crazy.


    Has anyone else experienced this? What could be the problem?


    I appreciate all the help I can get.

    Thanks
     
  2. Robyr macrumors regular

    Joined:
    Feb 21, 2010
    #2
    What year/tier model of Air? There was an issue on 2010's that I believe required an update, and I believe people with 2011's have reported needing to do an SMC reset to fix this. This is easy, and its probably worth a shot regardless of what model MBA you have.

    Also, are you hearing the fans spin up? They should be pretty well ramped at 80*C
     
  3. TheJing thread starter macrumors 6502a

    TheJing

    Joined:
    Jun 13, 2011
    Location:
    Somewhere in Europe
    #3
    When it goes all the way up to 90C the fans go crazy, yes. But as soon as it hits 80C they slow down to 2000rpm again and the temp still goes down pretty fast. I will try to do an SMC reset then and see how it goes.

    Thanks, btw.
     
  4. Robyr macrumors regular

    Joined:
    Feb 21, 2010
    #4
    No problem, report back and let us know how it goes.
     
  5. TheJing thread starter macrumors 6502a

    TheJing

    Joined:
    Jun 13, 2011
    Location:
    Somewhere in Europe
    #5
    I think I just did the SMC reset. How can I make sure it worked? I mean, how can I be sure that I did reset the SMC?
     
  6. Robyr macrumors regular

    Joined:
    Feb 21, 2010
    #6
    The MagSafe may have blinked, but if you followed Apple's instructions, it worked.
     
  7. TheJing, Jan 7, 2012
    Last edited: Jan 7, 2012

    TheJing thread starter macrumors 6502a

    TheJing

    Joined:
    Jun 13, 2011
    Location:
    Somewhere in Europe
    #7
    Ok. Thanks again. I'll see if it happens again today or tomorrow. If not, it probably solved the issue.



    UPDATE: Since I reset the SMC, I haven't had the problem so far. It doesn't happen every day so I'll see tomorrow.

    But one thing that I did notice is that my battery lasted longer, at least the estimated time remaining is noticeably longer than it used to be.

    It also appears to be running a little bit cooler than before. Right now I'm watching a movie in fullscreen on one desktop and browsing on another one and it stays between 50 and 53C.

    Maybe there was some process going on in the background constantly but the SMC rest killed it. I have no idea if that is even possible though, I'm no expert.
     
  8. TheJing, Jan 8, 2012
    Last edited: Jan 8, 2012

    TheJing thread starter macrumors 6502a

    TheJing

    Joined:
    Jun 13, 2011
    Location:
    Somewhere in Europe
    #8
    It just happened again. Just now I had only the Activity Monitor open, 98,88% idle and it was at 90C.

    I don't understand what is going on.

    UPDATE:

    I just read on the Apple forum that a lot of others are experiencing the same problem but it can be "solved" by:

    1. Waiting 2 minutes before opening the lid after you have plugged in the power supply in your sleeping Macbook Air
    2. Waiting 2 mites before plugging in the power supply after you have opened the lid on a sleeping Macbook Air.

    I never realized this, but as other said it only happens when the computer is in the so called "deep sleep mode".
    Therefore, another way to solve the issue is simply to disable "deep sleep mode".

    I would do that but I don't want my battery to drain 10% every night since I always put it to sleep when I fall asleep.
     

Share This Page