Unusual problem with Wifi connection

Discussion in 'Mac mini' started by arbj, Jan 4, 2017.

  1. arbj macrumors newbie

    Joined:
    Jan 30, 2013
    #1
    Hi,

    I have a Mac mini running on MacOs Sierra.

    I noticed an unusual problem with the mac min, this was not there when I bought it first (last year). I have a Apple airport extreme router at home which I use to connect to the internet. The mac mini does not connect to the SSID of the Airport, it tries to to connect for a long time, then comes up with the diagnostic dialog. I also have a macbook pro that connects easily to the Airport without any problems.

    Sometimes after switching off the mac mini, then switching on again after several hours I find that the mac mini connects easily, but even then if another network is selected, it does not re-connect to the Airport again.

    Has anyone had this kind of problem before ?? if so any suggestion on how I can resolve this ??

    I searched on the internet and found that, doing a SMC reset followed by a PRAM reset could solve this problem...Is this true ??

    Also I read that a PRAM reset could erase config data like timezone, hard disk setup etc. I am worried as I don't want to brick the system, cause I live in India, and I had bought the mini in the USA, I am not sure apple support in India will service my complaint.

    Also I have vital data stored in the mac mini I dont want to format or re-install the Operating system again.

    Please suggest a suitable solution ....

    thanks
    a
     
  2. bernuli macrumors 6502

    Joined:
    Oct 10, 2011
    #2
    I would try going into System Preferences -> Network -> Wi-Fi. Click the Advanced button, then delete all the Preferred Networks (click minus sign). Click OK to close Advanced.

    After that re connect to SSIDs you want to use. You will need to enter the network passwords again.
     
  3. Analog Kid macrumors 601

    Analog Kid

    Joined:
    Mar 4, 2003
    #3
    I had something similar happening under Yosemite, where I couldn't get one Mac to connect to the 5.8GHz network of my Netgear router if my iPhone was also connected to the 5.8GHz. No idea why. I think it must have been a radio compatibility problem. I just kept the Mac connected to the 2.4GHz network, which probably isn't the solution you want here.

    Still it's worth checking if there's a conflict with another device. If not, @bernuli's suggestion is a good starting place-- you can also create a new location and start fresh on all of the settings. I've found that sometimes deleting the WiFi interface from the network settings and adding it back in clears a glitch somewhere in the setup.

    Make sure you have a backup, that's just good practice when you have important data on a machine. It's probably overkill for something this simple, but if you have a spare drive around, make a second backup. Since you know you're going to be mucking with the machine, having a second recent backup means you'll always have two copies of the data even if you clobber something accidentally.

    I've never had data loss from resetting SMC or PRAM, but that doesn't mean it's impossible. You may need to fix some settings if you do it-- such as the timezone, and maybe some others-- but those are mostly convenience settings, not critical to system operation.

    Still, make good backups and disconnect them while you're doing all of this. I was just changing machines over a couple weeks ago and accidentally erased my backup drive. It was human error, not a system error-- I was doing too many things at once and confused myself. Still, it was really unnerving when I realized what I'd done. Fortunately, I still had the original data and a second backup.
     
  4. arbj thread starter macrumors newbie

    Joined:
    Jan 30, 2013
    #4
    thanks bernuli for that suggestion, I have already tried that several times.

    But I have noticed today that after removing the power cable for atlas 20 minutes, then restarting again solved the problem, but the problem re-appears after changing the SSID, then reverting back to the Airport Extreme.

    Thanks 'Analog Kid' for that tip on backup, I am going to backup the drive before proceeding for the PRAM reset.

    thanks
    a
     
  5. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #5
    I was going to suggest a PRAM and SMC reset. Let us know how that works for you.

    First though make sure your Airport is on the latest firmware. One of the bug fixes was for vanishing SSID's I believe. If I'm correct about that you could be directly effected by that bug.

    Oddly and I don't know if its related to the last Airport update a couple weeks ago but my iMac seems to be going to wifi N after a bit of time. I can't notice it in use and N is faster than my NAS can read write so its not really that important. But if I find some sort of solution involving reseting something I'll post back.

    Also I would try cycling the power on the Airport even though other devices connect just fine. Networking gremlins are a mysterious lot.
     
  6. bernuli macrumors 6502

    Joined:
    Oct 10, 2011
    #6
    Could you post the output of :

    sudo syslog | grep airportd

    perhaps someone here could interpret errors that might be getting logged.
     

Share This Page