Update 10.7.3 problems.

Discussion in 'MacBook Pro' started by Dorde, Feb 16, 2012.

  1. Dorde macrumors newbie

    Joined:
    Jul 26, 2008
    #1
    Hey everybody I just updated to 10.7.3. After I updated I tried to use Spotlight. The first problem was I would type about 2 letters then it would simply disappear then come back up a few seconds later but with nothing typed in it. So I did a safe boot and a disk repair which stopped it from disappearing but now spotlight won't even search my computer. It just asks to search the web or wikipedia. I went to Terminal and entered sudo mdutil -E /, did nothing. Should I just wait for an update from Apple or do you guys have any suggestions?

    I also just got my 256gb Crucial SSD, should I hold off on installing it until this problem is fixed?

    BTW I have an early 2011 13inch MBP 2.7ghz i7 with recently upgraded 8GB RAM.

    Thanks for any answers.
     
  2. lamboman macrumors 6502

    Joined:
    Aug 13, 2011
    #2
    As soon as I saw your thread title, I knew it would be about Spotlight!

    1) Open Activity Monitor in the Utilities folder.
    2) Find the mds process. Click Quit on the top left of the window, and click Force Quit.
    3) Open System Preferences, Spotlight, Privacy tab, add Macintosh HD, then remove it.
    4) Leave it for a second, and it should start reindexing. Wait for this to complete, and it'll be working again.

    I've been having issues with the index being deleted again; this has happened on both my MBP (which I'm just sorting as I type this) and on my iMac. I'll update tomorrow if this happens again, and provide a solution if I can.
     
  3. Dorde thread starter macrumors newbie

    Joined:
    Jul 26, 2008
    #3

    Tried that on my HD, didn't work so I swapped in my SSD. Everything works perfectly except for spotlight. I tried it on the SSD and still same problems.
     
  4. lamboman macrumors 6502

    Joined:
    Aug 13, 2011
    #4
    What happens? If you type the following:

    Code:
    sudo mdutil -s /
    Type your password, and it'll tell you whether indexing is enabled, or whether you have an error.
     
  5. Dorde thread starter macrumors newbie

    Joined:
    Jul 26, 2008
    #5
    It says "indexing is enabled".
    But when I let it re-index. It just keeps disappearing when I type then seems to reload itself just like before.
     
  6. lamboman macrumors 6502

    Joined:
    Aug 13, 2011
    #6
  7. yojitani macrumors 68000

    yojitani

    Joined:
    Apr 28, 2005
    Location:
    An octopus's garden
    #7

Share This Page