update 2G to 3.1.2 from 1.1.4 ? -complicated-

macordiefool

macrumors newbie
Original poster
Dec 10, 2009
25
0
Canada eh!
I asked a similar question before but thought I needed to be more specific as no matter where I looked I could not seem to get a solid answer.
The specifics are:

2G running 1.1.4 with a 04.04.05 baseband previously unlocked and jailbroken using pwnage 2.0.
I am experiencing problems with the phone freezing several times a day.

Should I upgrade to 3.1.2 considering the previous jailbreak, unlock etc? or do I understand correctly that this will also update my baseband and therefore make it impossible to unlock again?
Or should I option restore and choose restore from backup?
Since it was unlocked with pwnage will it remain unlocked after a restore or update?
I also read to never restore from a backup.
Is blackra1n an option or even necessary with previous pwnage jailbreak?

I have read all the tutorials possible BUT I have come across the occasional comment about the previous pwnage possibly causing an issue and an upgraded baseband being a nightmare.

So considering all the facts, what should I do?
btw I am running the latest itunes on a mac if it matters

Once again a sincere thank you to all.
 

cjmillsnun

macrumors 68020
Aug 28, 2009
2,399
45
The baseband on an original iPhone hasn't been updated since the iPhone 3G came out.

Go for your life. Pwnage tool should work fine.
 
Comment

Pared

macrumors 65816
Oct 19, 2007
1,127
1
Yes, blackra1n complicates things...

This gets mentioned as you post a 14 step guide as opposed to a 3 step guide....
 
Comment

superflush

macrumors 6502a
Apr 6, 2009
508
3
it is more complicated because you need to use blackra1n to jailbreak, and then another program to unlock.
If you use Pwnage Tool, it is just one program, and you restore the custom ipsw in iTunes.
 
Comment

Pared

macrumors 65816
Oct 19, 2007
1,127
1
No one was arguing. A disagreement does not constitute an argument.

Either way, the OP has more options and that's always good. They win.
 
Comment

macordiefool

macrumors newbie
Original poster
Dec 10, 2009
25
0
Canada eh!
Blackra1n even after unlock?

Thanks for the help.
I followed the link enoC gave me and it had a warning as follows
"Note: Do not update your iPhone to OS 3.1.2 yet if it is jailbroken or unlocked on firmware 3.1. Wait for the new jailbreaking and unlocking tools before updating your device or you may loose the capability to jailbreak or unlock your device in the future. You have been warned!"

That sounds like a bad idea.Has this been fixed? It is difficult to determine (for me)what is up to date and what isn't.

I am sure it is a lot easier than I am making it.
Thanks again for the fantastic forum.
 
Comment

thelatinist

macrumors 603
Aug 15, 2009
5,934
49
Connecticut, USA
Thanks for the help.
I followed the link enoC gave me and it had a warning as follows
"Note: Do not update your iPhone to OS 3.1.2 yet if it is jailbroken or unlocked on firmware 3.1. Wait for the new jailbreaking and unlocking tools before updating your device or you may loose the capability to jailbreak or unlock your device in the future. You have been warned!"

That sounds like a bad idea.Has this been fixed? It is difficult to determine (for me)what is up to date and what isn't.

I am sure it is a lot easier than I am making it.
Thanks again for the fantastic forum.
1) this has been fixed.
2) it never applied to your 2G iPhone to begin with.
3) just download blackra1n and run it. Then use the new app "blackrain" on your springboard to install Cydia. Finally, use Cydia to install Bootneuter. Run BootNeuter and set the unlock toggle to unlocked.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.