iPhone update 3GS on 4.2.1 to 5.1.1 (or 6?)

Discussion in 'Jailbreaks and iOS Hacks' started by striderzero, Apr 28, 2013.

  1. striderzero macrumors newbie

    Joined:
    Apr 28, 2013
    #1
    Hello

    I have an iPhone 3GS (new boot rom) currently on 4.2.1 (jailbroken, unlocked), baseband : 05.13.04

    I would like to update to 5.1.1 untethered and preserve baseband, I tried a few times with redsn0w but failed until now.

    Here is what I did after reading a few tutorials:

    -Created a custom no BB IPSW with redsn0w
    -Edited the hosts file with a # before the [74.208.10.249 gs.apple.com] line
    -Started iPhone in pwned DFU mode
    -Tried to update through iTunes with custom IPSW but I got the "iPhone could not be restored because the firmware file is not compatible'." error message.

    Redsn0w warned me that with new boot rom 3GS, SHSHs would be necessary, unfortunately the only SHSH blobs I have are for 4.1 and 6.1.3.

    I suppose this is an issue with the SHSHs.

    Is there any way for me to update to 5.1.1 without the SHSH blobs? or am I doing anything wrong in the update procedure?

    If it's not possible to update to 5.1.1, is there a way to update to 6.1.3 while preserving bb?

    Thank you! :)
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    That is what your missing, shsh blobs for 5.1.1. It is not possible to update without shsh blobs
     
  3. striderzero, Apr 28, 2013
    Last edited: Apr 28, 2013

    striderzero thread starter macrumors newbie

    Joined:
    Apr 28, 2013
    #3
    Hi

    Thanks for your reply!
    Ok, so at least I know I don't need to spend more time trying to update to 5.1.1

    I'll try to update to 6.1.3

    Edit:
    By the way, is ultrasn0w working on 6.1.3 (new boot rom)? I can't find detailed info on this.
     
  4. novice121 macrumors member

    Joined:
    Feb 15, 2013
    #4
    DO NOT UPGRADE to 6.1.3, if you have a new BR then you will have a very annoying tethered jailbreak!

    If you truly already did a factory IMEI unlock, then it doesn't matter if you upgrade the baseband, you will keep a permanent IMEI unlock, altough you can upgrade to any version without upgrading the baseband of you want.

    I believe only old BR 3GS can have an untethered 6.1.3 jailbreak.
     
  5. striderzero thread starter macrumors newbie

    Joined:
    Apr 28, 2013
    #5
    Thanks for your message. :)

    I currently rely on ultrasn0w to unlock
    IMEI unlock is quite expensive for my phone on myimeiunlock.com (Japanese 3GS, Softbank), so I'd prefer to find another solution.
    Although tethered is indeed annoying, if ultrasn0w supported 6.1.3 I would still update and do tethered jailbreak. The problem with iOS 4.x is that many apps aren't supported.
    But from what I could find, it seems that ultrasn0w hasn't been updated for 6.1.3

    I'll try to search a bit more, but if there's nothing I'll go for IMEI unlock.
     
  6. novice121, Apr 28, 2013
    Last edited: Apr 28, 2013

    novice121 macrumors member

    Joined:
    Feb 15, 2013
    #6
    I don't know how much an IMEI unlock goes for elsewhere, but here in the US, I only paid 6 U$D, which is really cheap. I also tried a software unlock before, but wasn't reliable at all, and it's really old. IMEI unlock is the sure thing.


    I guess you'll have to ask this guy if he can IMEI unlock your phone from here, because I don't know:

    Code:
    http://fastiphoneunlocks.webs.com/
    Just ask, it's fast (maybe 8 hours wait until they e-mail you), but you have to be on baseband 05.13.04 for them to do it.

    PS: nevermind, it says USA iphones only. I guess you can ask this guy for cheap japanese IMEI unlocks, he says he can find everything cheap:

    Code:
    http://forums.macrumors.com/member.php?u=690002
     
  7. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #7
    Did you ever try a tethered JB?
     

Share This Page