iPhone Update from IOS 4 to IOS 6

Discussion in 'Jailbreaks and iOS Hacks' started by Ichkamo, Aug 1, 2014.

  1. Ichkamo macrumors member

    Ichkamo

    Joined:
    Jun 13, 2013
    Location:
    World Wide Web
    #1
    Hi,
    I have an iPhone 4 with IOS 4.0 (8A293) on it, and I would like to update it to IOS 6.1.3, (or any IOS 6). The problem is : iTunes won't accept to update using IOS 6.1.3 IPSW files saying : "the device isn't eligible for the requested build". I have a windows VM so I can use apps like iFaith and stuff... I made a signed IOS 6.1.3 IPSW file using iFaith but when I tried to restore or update the iPhone using that file iTunes wouldn't do it saying that the firmware file isn't compatible... :/
    There must be a way to do what I'm trying to do but I'm a NOOB in jailbreaking and stuff... Please help me :)
    Thanks a lot. :):apple::)
     
  2. HankHowdy macrumors 68040

    HankHowdy

    Joined:
    Dec 2, 2012
    Location:
    Victorville CA
    #2

    You can't install old firmware. You have to install the latest software.

    There is a way, but you must have saved blobs while on 6.1.3. Since you were never on 6.1.3 you won't have any blobs.

    You will have to install 7.1.2.
     
  3. bkends35 macrumors 6502a

    bkends35

    Joined:
    Feb 24, 2013
    Location:
    USA
    #3
    Apple only allow users the upgrade or restore to the latest version of iOS 7. So the answer is no, you cannot upgrade to iOS 6.
     
  4. Ichkamo thread starter macrumors member

    Ichkamo

    Joined:
    Jun 13, 2013
    Location:
    World Wide Web
    #4
    Is there any illegal way to do that? Like jailbreaking to update and restoring back to legal apple software once I'm on IOS6?
     
  5. HankHowdy macrumors 68040

    HankHowdy

    Joined:
    Dec 2, 2012
    Location:
    Victorville CA
    #5

    You won't be able to be on iOS 6 if you don't have blobs that belong to that device.
     
  6. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #6
    Did you make sure you used a valid and complete 6.1.3 SHSH blob when making the signed custom ipsw? Did you put the device in PWNed DFU mode before restoring in iTunes using the custom ipsw?

    Make sure your hosts file points to Apple and not cydia

    Type "gs.apple.com" in your web browser. If it goes to cydia, you need to fix your hosts file

    If it's correct, it'll go to an apple placeholder website
     
  7. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
    #7
    Thats actually pretty awesome to have a 4.0 iphone 4! Like i seriously would not update that ever
     
  8. KingShoot007, Aug 2, 2014
    Last edited: Aug 2, 2014

    KingShoot007 macrumors member

    Joined:
    Jul 19, 2013
    Location:
    Starfleet Academy
    #8
    You must have 6.1.3 SHSH blobs for your to upgrade to a full working version of 6.1.3. Other then that , you can go only to 7.1.2.

    EDIT:
    Something has occurred to me. You can try doing a tethered upgrade.But your battery life will be shorter and you will be stuck with a tethered jailbreak. Comment bellow if you want instructions
     
  9. Ichkamo thread starter macrumors member

    Ichkamo

    Joined:
    Jun 13, 2013
    Location:
    World Wide Web
    #9
    My blobs are real blobs made with iFaith with another iphone 4 in IOS6.1.3. I'm pretty sure they are good.

    I don't know what to do... Maybe I'll stay in IOS4, problem is, I won't be able to download any apps... :/
    Because I'm NEVER going to IOS7 and I'm not sure I want to jailbreak it if it does reduce battery life...
    If there really is no way to do that then that's kinda sad...
    Anyway, thanks alot for your help guys, I appreciate it. :)
     
  10. goobot macrumors 603

    goobot

    Joined:
    Jun 26, 2009
    Location:
    long island NY
    #10
    Blobs have to come from your device.
     
  11. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
    #11
    If you can afford it, I'd pick up a new in box iPhone 5. You get iOS 6 and a much better phone!
     
  12. HankHowdy macrumors 68040

    HankHowdy

    Joined:
    Dec 2, 2012
    Location:
    Victorville CA
    #12



    Poster is right. Blobs have to be from YOUR device to make custom ipsw when downgrading.

    What you are trying to do is impossible.

    If it was then no one would ever loose their jailbreak.
     
  13. iphoneDanSquaad macrumors newbie

    Joined:
    Aug 5, 2014
    #13
    Can I have that

    Hey man...I'm having the same problem and I would like to know if anybody has a link for me to download a SIGNED ios 7.1.2 or 6.1.3....please help...
     
  14. Tyler23 macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #14
    iOS 7.1.2 is the most recent version of iOS, so it is still being signed. You can upgrade to that no problem.

    6.1.3 is no longer signed, so there is now update to that unless you have full blobs.

    No one can send you a link to a "signed" version, as it has nothing to do with the file, it has to do with Apple's servers.
     
  15. iphoneDanSquaad macrumors newbie

    Joined:
    Aug 5, 2014
    #15
    We'll my iphone 5 is bricked and I have shsh blobs for a 7.1.2 I got them from apple servers..........So I'm wondering which CUSTOM ipsw I could use to place an so on the phone....because iTunes is not allowing me to update just like that I need a custom ipsw in order to update
     
  16. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #16
    You can update to the latest version (7.1.2 currently) or any other one that might still be signed as well (usually that means no other ones, but at the moment it seems 7.1.1 might still fall under that category).
     
  17. iphoneDanSquaad macrumors newbie

    Joined:
    Aug 5, 2014
    #17
    So you are saying that ios 7.1.1 has a custom?
     
  18. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #18
    There is no custom. There's only what Apple provides and only what is being signed can be installed (at this point it's the latest 7.1.2 and apparently 7.1.1 as well for now).
     
  19. iphoneDanSquaad macrumors newbie

    Joined:
    Aug 5, 2014
    #19
    So 7.1.2 can be signed and be used as a custom right....please say yes
     
  20. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #20
    7.1.2 is already signed by Apple and can be installed as it is (nothing about it can be changed).
     
  21. Paddle1 macrumors 68030

    Joined:
    May 1, 2013
    #21
    You can install iOS 7 if you want to use apps, if you don't like it you can downgrade.
     
  22. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #22
    Return the iPhones you "bought" or were "returned from the police". Whichever story you feel like sticking to

    http://forums.macrumors.com/showthread.php?t=1762160

    http://forums.macrumors.com/showthread.php?t=1762045
     
  23. Pitmaster macrumors member

    Joined:
    Jul 13, 2014
    #23
    Yes.
     
  24. Anonymous Freak macrumors 601

    Anonymous Freak

    Joined:
    Dec 12, 2002
    Location:
    Cascadia
    #24
    Hey, he posted in another thread...

    Which is the same name as a Twitter account @ShakeilAdams3 that says he's in Guyana (South America,) and by the picture, looks fairly young.

    Shakeil, please stop trying in many different threads to figure out how to make your stolen phone work - it isn't possible. Time to face reality and stop stealing, and try to do something good.

    Hey, go to the Alpha United vs. Portland Timbers match tonight in Georgetown, that'll make you feel better.
     

Share This Page