Update hangs on TOU page, wake/sleep button broken

Discussion in 'iPhone Tips, Help and Troubleshooting' started by undertone54, Sep 19, 2013.

  1. undertone54 macrumors newbie

    Joined:
    Sep 19, 2013
    #1
    My iPhone 4S upgrade to iOS 7 is stuck on the Terms and Conditions page. Clicking 'Agree' does nothing.

    I've read that a reboot can fix this but my wake/sleep button is broken and I can't hard reboot. I also can't accept the T&C from another device because the only other one I have is the 1st gen iPad which isn't eligible for an iOS 7 upgrade.

    I tried restoring through iTunes but it won't let me until I turn off Find My iPhone which I can't do through my phone. I logged into iCloud and removed the phone from the Finder which still doesn't allow me to restore through iTunes and which I now probably regret since I can't erase remotely now either.

    Any suggestions? (Besides new phone, which I intend to get but would rather not be phoneless until then!)
     
  2. undertone54 thread starter macrumors newbie

    Joined:
    Sep 19, 2013

Share This Page