Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

savannadavis

macrumors newbie
Original poster
Sep 20, 2012
2
0
I updated my iPhone 4S yesterday and now I cannot send picture messages. it is driving me insane. I have unlimited messaging so there's no reason it should not work. I tried restarting my phone and a message pops up and says that MMS requires a phone number.. my number is correct, and it still fails to send.
 

SandboxGeneral

Moderator emeritus
Sep 8, 2010
26,482
9,998
Detroit
I updated my iPhone 4S yesterday and now I cannot send picture messages. it is driving me insane. I have unlimited messaging so there's no reason it should not work. I tried restarting my phone and a message pops up and says that MMS requires a phone number.. my number is correct, and it still fails to send.

Are you trying to use iMessage or a regular cellular text [SMS/MMS] message?

Go to Settings, then Messages and scroll down. Ensure MMS Messaging is switched on.
 
Comment

SandboxGeneral

Moderator emeritus
Sep 8, 2010
26,482
9,998
Detroit
neither work, iMessage and regular text messages. And MMS is switched on.

Under Settings --> Phone --> My Number, is your correct telephone number there?

Under Settings --> Messages --> Send & Receive --> You can be reached by iMessage at, do you have your telephone number selected as well as an email address?

Under Settings --> Messages --> Send & Receive --> Start new conversations from, is your telephone number selected there?
 
Comment

texasbelle9

macrumors newbie
Sep 20, 2012
1
0
Update iOS 6 and still can't send pics

I double checked all those sections and I still cannot send or receive pictures through iMessage either. :-/
 
Comment

Zakoson2120

macrumors newbie
Sep 21, 2012
3
0
I can't either I've tried several times and it always fails. It worked fine until I updated yesterday to IOS 6. It's getting frustrating.
 
Comment

Zakoson2120

macrumors newbie
Sep 21, 2012
3
0
I don't know why it's not working it was working flawlessly then I upgraded now nothing can't send pictures in iMessage or in a standard MMS... What a let down.
 
Comment

Zakoson2120

macrumors newbie
Sep 21, 2012
3
0
I can't send or recieve them over 3G or WIFI... Which sucks. Any idea when they will update this issue?
 
Comment

Felicide

macrumors newbie
Dec 17, 2011
25
0
Under Settings --> Phone --> My Number, is your correct telephone number there?

Under Settings --> Messages --> Send & Receive --> You can be reached by iMessage at, do you have your telephone number selected as well as an email address?

Under Settings --> Messages --> Send & Receive --> Start new conversations from, is your telephone number selected there?

I'm having the same issue. I tried looking at these three.
Under my number, yes my number is there.
Under iMessage, no my telephone number is not selected but an email is (messages are sending through iMessage with email)
Under send and receive, my telephone number is grayed so I cannot select it.

Also, when I turn iMessage on it says "waiting for activation" and nothing ever happens after that.
 
Comment

ndredsox

macrumors newbie
Sep 5, 2009
12
2
I'm having the same issue. I tried looking at these three.
Under my number, yes my number is there.
Under iMessage, no my telephone number is not selected but an email is (messages are sending through iMessage with email)
Under send and receive, my telephone number is grayed so I cannot select it.

Also, when I turn iMessage on it says "waiting for activation" and nothing ever happens after that.

Having the same issue. I did an erase iPhone via find my iPhone yesterday and since then it has not allowing imessage or facetime. I am wondering if I have to wait 24 hours after I wiped. I have tried everything, including a restore as a new iPhone.

Did you happen to erase from find my iPhone?
 
Comment

SandboxGeneral

Moderator emeritus
Sep 8, 2010
26,482
9,998
Detroit
I'm having the same issue. I tried looking at these three.
Under my number, yes my number is there.
Under iMessage, no my telephone number is not selected but an email is (messages are sending through iMessage with email)
Under send and receive, my telephone number is grayed so I cannot select it.

Also, when I turn iMessage on it says "waiting for activation" and nothing ever happens after that.

Check your iTunes account on the phone and be sure it's signed it. That's really the last thing I can think of to check, save doing a full restore.
 
Comment

Richard A

macrumors member
Feb 18, 2010
50
2
Can't send pictures using iMessage over my wireless network either, but can using LTE. Went to a friends house and was able to send on their network.

For those having this issue, are you using Comcast for your home network? My is and doesn't work, my friends's network is not Comcast and it worked there.
 
Comment

komiothebeat

macrumors 6502
Jul 8, 2008
398
4
Corona, CA
my phone seemed to be freaking out yesterday when i got it, not until making a few phone calls (to parents and friends) and then switching LTE on, THEN off again, that my messages and everything started working again
 
Comment

ZacNicholson

macrumors 6502a
Jun 25, 2011
875
1,070
Indiana
my imessage is working but not the mms. it was working fine on ios 5. but since i updated it doesn't work. i want to be sexting with this girl and she is to poor to have an iphone.
 
Comment

Grams452

macrumors newbie
Sep 23, 2012
1
0
I updated my iPhone 4S yesterday and now I cannot send picture messages. it is driving me insane. I have unlimited messaging so there's no reason it should not work. I tried restarting my phone and a message pops up and says that MMS requires a phone number.. my number is correct, and it still fails to send.

My grandsons did that I went to settings then phone then I just saves his number now he can send pics
 
Comment

DenverSteveo

macrumors newbie
Sep 22, 2012
3
0
Can't send pictures using iMessage over my wireless network either, but can using LTE. Went to a friends house and was able to send on their network.

For those having this issue, are you using Comcast for your home network? My is and doesn't work, my friends's network is not Comcast and it worked there.

I confirmed that this seems to be the case when I arrived at work this morning. I can send photos via Wi-Fi just fine across my office's "non-Comcast" network. I also had success this morning at Starbucks sending photos via iMessage, MMS, and email.

At this point, it seems as if IOS 6 and Comcast aren't playing well together...

Can anyone else confirm that their issues are limited to connectivity over a Comcast network?
 
Comment

Foo4Everlong

macrumors member
Jun 23, 2010
58
20
Yes, I have Comcast as well and ever since the iOS 6 update I have not been able to send MMS through wifi both on my iPad and on my new iPhone 5. I can send text through iMessage but not pictures or videos. I tried rebooting my wifi recently to no avail. I did not reset the wifi I just unplugged for several minutes. I believe here is a reset button on the wifi. Just as extra info I have a Comcast XFinity wifi box. I can send through 4G no problem. And I also was at another place with different wifi and I was able to send both pictures and text from there. This issue is driving me nuts as I enjoy sending pics. Oh, by the way, my iPad 1 which did not get the iOS 6 update can send pictures and videos through wifi. Please any help would be greatly appreciated. Thanks much. Later
 
Comment

DenverSteveo

macrumors newbie
Sep 22, 2012
3
0
Here is a solution that came up on the Apple Support Forum regarding this issue:

"Well I spent a hours on the phone with Apple care and the guy submitted a ticket to the higher ups. Nothing ever came of that though. I figure that the iphone 5 has to be sending pics/videos through a different port or with added security and the xfinity gateway blocks it.

I called Comcast yesterday and the rep was trying to turn my gateway into just a modem, but it wouldn't listen to her commands. I decided that it's not worth the hassle and am returning the gateway to comcast. I went out and bought a stand alone comcast modem for $99 at best buy, but if you don't want to do that, you could always just exchange the gateway for a separate modem and router at the comcast office. My parents have comcast and they rent their modem and router from comcast, but the router is netgear and is a separate unit.

So my current set up is a comcast cable modem: Motorola Surfboard docsis 3.0 high-speed cable modem and an older b/g netgear router that I had in the closet. Everything works great and my iMessage can now send photos and videos with no issues. The Xfinity gateway is the issue, at least for me it was."


I'm guessing that this may be the issue that quite a few of us are experiencing. I hope it helps!
 
Comment

Msyspencer

macrumors newbie
Sep 24, 2012
1
0
I have a modem and wireless router not bought from Comcast although I have Comcast Internet service, and I'm unable to text pictures to anyone without iOS 5 or 6. I can't send to them while connected to wifi nor mobile Internet (tmobile so no 3G).
 
Comment

ITS ME DAVID

macrumors 6502
Jul 13, 2010
343
0
Pasadena, Ca
I'm having the same problems on my new iPhone 5 and 4s with ios6 on the other line with att I reset networks did a hard reset even restored and nothing I have mms enabled my phone # is listed under my phone settings etc
 
Comment

Illest

macrumors newbie
Sep 28, 2012
19
3
Bay Area, California.
Here is a solution that came up on the Apple Support Forum regarding this issue:

"Well I spent a hours on the phone with Apple care and the guy submitted a ticket to the higher ups. Nothing ever came of that though. I figure that the iphone 5 has to be sending pics/videos through a different port or with added security and the xfinity gateway blocks it.

I called Comcast yesterday and the rep was trying to turn my gateway into just a modem, but it wouldn't listen to her commands. I decided that it's not worth the hassle and am returning the gateway to comcast. I went out and bought a stand alone comcast modem for $99 at best buy, but if you don't want to do that, you could always just exchange the gateway for a separate modem and router at the comcast office. My parents have comcast and they rent their modem and router from comcast, but the router is netgear and is a separate unit.

So my current set up is a comcast cable modem: Motorola Surfboard docsis 3.0 high-speed cable modem and an older b/g netgear router that I had in the closet. Everything works great and my iMessage can now send photos and videos with no issues. The Xfinity gateway is the issue, at least for me it was."


I'm guessing that this may be the issue that quite a few of us are experiencing. I hope it helps!

I'm experiencing the samething. My temporary fix is to turn off WiFi, send the MMS and then turn wiFi back on, but this is only when I'm home.

Does anyone know a better solution?
 
Comment

LordQ

Suspended
Sep 22, 2012
3,582
5,651
Sorry to bring this up again but has anyone found a solution for this terrible bug? I can't send photos through WhatsApp, Mail, Facebook (it won't even load new notifications) I can't search on Soundhound, can't share photos on Instagram and can't make FaceTime calls...

This is driving me crazy. First time I'm losing patience with an Apple product...
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.