Update killed my MacBook

Discussion in 'MacBook Air' started by Ifti, Oct 23, 2013.

  1. Ifti macrumors 68000

    Joined:
    Dec 14, 2010
    Location:
    UK
    #1
    I have a 2013 model - spec in sig.

    Today I switched on my MBA as normal and got nothing - straight into the OSX Utilities screen.

    Tried choosing a startup disc - nothing.

    Rang Apple - repaired drive permissions etc and still got the same. It was as though my drive was completely empty! They just advised me to reinstall OSX cleanly!!! Some solution that is!

    Tried a Time Machine restore from my TC - it finished the restore and then did the same thing again!!

    Tried connecting an external drive to boot off of an image - it wouldn't even recognise the drive.

    In the end I had to completely reinstall Mountain Lion from scratch then use migration assistant to get all my data and apps back.

    I then upgraded to Mavericks fine.

    The only thing I did was the recent firmware update to the MacBook Airs - but that was 2 days ago and it wood fine until today!!

    Any ideas why this happened??
    It was as though suddenly I had a completely empty drive all of a sudden!! Rather worrying!
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    That sounds like you have a drive on the way to a dirt nap. :eek:

    Try a command-r boot to recovery and run a repair disk with Disk Utility. Also run Apple Diagnostics.
     
  3. DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #3
    glitched install? something weird about the package downloaded that wasn't caught before install started? who knows... it works now, right? hopefully it's not a bad drive but i would definitely make regular backups!

    i'm sure that was a stressful couple of hours while you waited :(
     
  4. Ifti thread starter macrumors 68000

    Joined:
    Dec 14, 2010
    Location:
    UK
    #4
    It was indeed!! lol

    Just updated to Mavericks and made another TM backup straight away. Will create a image tomorrow also ;)
     
  5. DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #5
    Out of curiosity did you happen to catch the size of that first tm backup after install?
     

Share This Page