Update/restore iphone 4, error 21, 1601

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cprewe, Nov 17, 2012.

  1. cprewe macrumors newbie

    Joined:
    Jun 11, 2012
    Location:
    Venice
    #1
    I've gone through the threads and used google to search solutions, and I must be doing something wrong. If someone could help me that would be great.

    I jailbroke my phone hoping to be able to unlock and use it abroad (I'm based in the US, planned to be in UK)nearly 2 years ago, and I was very up on doing the updates and whatnot, but then it got tedious and I couldn't be bothered. Now I find myself with an iphone that can't upgrade apps because iOS 5 is required. I don't really need the jailbreak immediately, I would like to have it eventually, but I really just want a more current phone.

    I've tried just restoring in itunes and got error 21. So then I tried in DFU(using redsnow), and got 1601. I tried changing hot files in terminal. It doesn't seem to matter what I do, I just keep getting one of those 2 errors.

    If someone could walk me through, that would be great. I've been at this for hours today and now I'm finally to the point where I'll actually bug someone for assistance.

    Cheers in advance.

    iphone 4
    version 4.2.1 (8C148)
    firmware 2.10.4

    macbook pro mid 2010
    OSX Lion 10.7.5
     
  2. JamesWilliams12 macrumors member

    Joined:
    Nov 13, 2012
    #2
    Hi, try to fix this with latest redsn0w, go to extras > fix recovery.
     

Share This Page