Update to 10.13.2 - Safari, Mail, App Store not more working

Discussion in 'macOS High Sierra (10.13)' started by d4gli, Dec 6, 2017.

  1. d4gli macrumors member

    d4gli

    Joined:
    Jun 15, 2016
    #1
    Hey,

    after upgrading to 10.13.2 my Safari, Mail and AppStore stopped working.
    I can see new Email elements, but not the content (won't load the body). Safari stopps displaying in the half of loading and Appstores keeps the gray background.

    Seems like everything based on Webkit stopped working... Any hints?
    --- Post Merged, Dec 6, 2017 ---
    Final 10.13.2 killed working my Safari, Mail & Appstore (seems to be related to all Apple Webkit Apps).
    Running PRam/NVRAM Reset (Shutdown, turn on and press immediately ALT + CMD + P + R) fixed it. CSR has been reactivated; make sure to reboot recovery/usb to disable it again.
     
  2. Jesla macrumors 6502

    Jesla

    Joined:
    Jan 7, 2013
    Location:
    Tennessee USA
  3. CTHarrryH macrumors 68000

    Joined:
    Jul 4, 2012
  4. Sdtrent macrumors newbie

    Sdtrent

    Joined:
    Feb 15, 2017
    #4
    Things have been fine so far for me but I'm glad you got it working!
     
  5. krishnameena macrumors newbie

    krishnameena

    Joined:
    Dec 7, 2017
    #5

    I am also facing same issues.
     
  6. unbiased macrumors newbie

    unbiased

    Joined:
    Sep 10, 2010
    Location:
    Columbus, Ohio
    #6
    I am as well - Safari, Firefox, App Store - oddly Chrome is working. I can terminal and ping google.com successfully. I am on a 2009 MacBook Pro using the DosDude1 method to apply Sierra and also High Sierra... All worked until now. Appearance and functionality is there but some applications appear to struggle to access Internet.
    --- Post Merged, Dec 7, 2017 ---
    Never mind - the update mentioned Alt-Command-P-R resolved my issues. Thanks!
     
  7. Hackintosh HD macrumors newbie

    Hackintosh HD

    Joined:
    Sep 27, 2017
    #7
    I've had the same problem on a MacBookPro5,2 mid-2009 where an NVRAM reset wouldn't resolve it. An OnyX automation run with default settings however did.

    Interesting detail: Not only Apple's WebKit apps Safari and the Mac App Store wouldn't render anything, but also Firefox Quantum was affected as far as it would have its first tab crash on launch.
     
  8. Caine85, Dec 7, 2017
    Last edited: Dec 7, 2017

    Caine85 macrumors newbie

    Caine85

    Joined:
    Dec 7, 2017
    #8
    For me, resetting the PRAM did not solve the problem. Safari, App Store and Mail still do not work.

    OnyX (https://www.titanium-software.fr/en/onyx.html) instead works like a charm!

    I'm using macOS High Sierra 10.13.2 on MacBook Pro Mid 2009 with dosdude1 High Sierra Patcher Tool.

    Thank you so much!
     
  9. amondror macrumors newbie

    Joined:
    Dec 7, 2017
    #9
    A same with my macpro Safari (& Firefox) & Apple Store & Email not functions.
    the Firefox & safari open but cant show any web.
    Email received Email but not show the text body.
    Apple Store open but not show anything.
    Google Chrome & Map & Note & Calendar working OK .
    Unfortunately Command & Alt &P&R not fix the problem.
     
  10. AthanasiosK macrumors newbie

    AthanasiosK

    Joined:
    Dec 7, 2017
    #10
    Exactly Same thing here
     
  11. EugW macrumors 68020

    EugW

    Joined:
    Jun 18, 2017
    #11
    Are your machines officially supported by 10.13 or not?

    No issues on my 3 fully supported Macs.

    However, I got the same exact Safari/App Store issue on my 2 non-supported Macs running patched 10.13. To fix it I ran OnyX's Automation script.

    https://www.titanium-software.fr/en/onyx.html

    My sig below has the specs of these 5 Macs.
     
  12. amondror macrumors newbie

    Joined:
    Dec 7, 2017
    #12
    thank you very mach! After I used OnyX it working thank you again
     
  13. dblissmn macrumors regular

    Joined:
    Apr 30, 2002
    #13
    10.13.2 so far seems significantly less flaky than 10.13.1, which I had to advise people at work to stay away from. There still seem to be some mirroring/spanning bugs on second monitors but only one hard freeze so far which is an improvement believe it or not. Once again the update process was fraught; two of my computers hung during the update and had to be rescued with Ethernet cable which got the ball rolling again; this business of the computers losing WiFi network connectivity during an update process is a PITA. There are so many posts of people having their updates hang with the progress bar about one-third of the way through just as it is allegedly starting to calculate the time remaining; every time this has happened to me in Sierra it is because the computer has lost the network connection on WiFi and every time the fix is a good old Ethernet cable from the router or modem. Never happened to me before High Sierra.

    Wish Apple would get these bugs sorted; they're pretty basic. I'd like to see the level of quality in 10.3 or 10.4; this is getting too much like 10.1 in the early days of OS X.
    --- Post Merged, Dec 7, 2017 ---
    How have you "patched" the unsupported Macs -- what kind of mod to the OS, or did you do something like replace the WiFi cards with newer ones that have the necessary chipset?
     
  14. EugW, Dec 8, 2017
    Last edited: Dec 8, 2017

    EugW macrumors 68020

    EugW

    Joined:
    Jun 18, 2017
    #14
    No hardware mods. Just a software patch.

    http://dosdude1.com/highsierra/

    Note that this mainly only works on 2008-2009 Macs, although a few Macs may need hardware mods as you suggest. My 2008 MacBook5,1 and 2009 MacBookPro5,5 didn’t need hardware mods as they have basically the same internal hardware as the fully supported 2009 MacBook6,1.
     
  15. Mike I macrumors newbie

    Joined:
    Dec 11, 2017
    #15
    ... I thank you soooo much. I was going nuts and your guidance to OnyX was crucial. Not only did it solve my Mail, and Safari problem by my Excel for Mac 2008 which before this fix would tell me I didn't have enough memory to open (anything.) So once again, thank you. Have a blessed and Merry Christmas!
     
  16. FloridaAppleMacPros macrumors newbie

    FloridaAppleMacPros

    Joined:
    Dec 14, 2017
    #16
    I wonder how many of us who've had this happen, have used a patcher tool to get Sierra or HS on our comp uters?
    WIll try Onyx shortly.
     
  17. ach macrumors newbie

    ach

    Joined:
    Dec 13, 2012
    #17
    Yes, same with me on MB 5.1. I tried the Public Beta also with no luck. I had to reinstall 10.13 twice to get a usable system. What did you folks do, did you ever got it to work?

    Hold it, you folks tried two methods that worked. I'll update it after I try the two. Thanks.


    I really have so much problems with High Sierra that I had to avoid it on my 2008 Mac Pro also.
     
  18. ach, Dec 16, 2017
    Last edited: Dec 16, 2017

    ach macrumors newbie

    ach

    Joined:
    Dec 13, 2012
    #18
    Onyx worked after running all maintenance and cleaning cache scripts. Thanks!

    Has anyone figured out how to get sleep to work on the 2008 Mac Pro with HD5770?
     
  19. SaintsDesigns macrumors newbie

    Joined:
    Oct 23, 2012
    #19
    Using OnyX worked for me, I tried everything else but only this worked :)
     

Share This Page