Update to 4.1 and PwnageTool jailbreak fixed my No SIM issue

Discussion in 'Jailbreaks and iOS Hacks' started by TitanTiger, Oct 22, 2010.

  1. TitanTiger macrumors 6502

    Joined:
    Jun 8, 2009
    #1
    I couple of months ago I posted here about how a crash to one of my Cydia apps caused me to have to rejailbreak my phone and after that and the ultrasn0w unlock, the phone wouldn't recognize my SIM card. I tried everything...got a new SIM from TMobile. Re-did the jailbreak using redsn0w, JailbreakMe.com and PwnageTool. My friend's AT&T SIM cards worked and so did a friend's TMobile SIM, but not mine.

    Well last night I did the update to 4.1 and the jailbreak using PwnageTool. Unlocked it again. Still nothing. Pop in my SIM and nothing happens. Even after a reboot.

    Today, on a lark, I borrowed my friend's iPhone and put her AT&T SIM in it. Worked great. Put my TMobile SIM in her phone and hers at least sees my SIM and says "Invalid SIM." I mucked around looking at a few settings but didn't change anything, then switched them back. For the first time, instead of the No SIM message, it went to "No Service" then a few seconds later the bars appear, then TMobile! I've made some calls and texts. It works great again.

    What do you suppose happened here? Was putting a legit SIM in the phone after the software update something that might have triggered it or what?
     
  2. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #2
    More than likely pwnage tool and reinstalling ultrasn0w fixed your issue. The reason it probably worked after messing around with the ATT sim is that you powered the phone off and on. The reboot from the power off is probably responsible for fixing it not the att SIM.
     
  3. TitanTiger thread starter macrumors 6502

    Joined:
    Jun 8, 2009
    #3
    Actually I didn't reboot it. I just hotswapped the SIM cards.

    And I had restored and redone PwnageTool on 3.1.3 and uninstalled and reinstalled ultrasn0w at least 10 times before already.
     
  4. TitanTiger thread starter macrumors 6502

    Joined:
    Jun 8, 2009
    #4
    Well, that was short lived. Worked all day long. Made multiple calls and sent several texts. Was getting ready to go somewhere tonight and pulled the phone out of my pocket...No SIM. Haven't been able to get it to work since. *sigh*
     

Share This Page