Update to 4.3.1 and preserve baseband HELP!!!

Discussion in 'Jailbreaks and iOS Hacks' started by Coleman2010, Apr 7, 2011.

  1. Coleman2010 macrumors 68000

    Joined:
    Oct 9, 2010
    Location:
    NYC
    #1
    I followed the instructions here and I'm stuck!

    http://www.freakgeeks.com/2011/4645...t-updating-baseband-with-use-of-tinyumbrella/

    I downloaded the new tiny umbrella and started server clicked option restore in iTunes and pointed to the 4.3.1 firmware on my desktop. It updated to 4.3.1 then gave the appropriate error in iTunes. I quit iTunes as instructed and downloaded the recovery fix from the TU site. When I try to run it it opens in terminal and I get the following:

    Last login: Thu Apr 7 06:25:41 on ttys000
    /Users/carlos/Downloads/fixrecovery-osx-1/fixrecovery43 ; exit;
    Carlos-MacBook-Pro-17:~ carlos$ /Users/carlos/Downloads/fixrecovery-osx-1/fixrecovery43 ; exit;
    Initializing libpois0n
    No matching processes belonging to you were found
    Waiting for device to enter DFU mode
    opening device 05ac:1281...
    Setting to configuration 1
    Setting to interface 0:0
    opening device 05ac:1281...
    Setting to configuration 1
    Setting to interface 0:0
    opening device 05ac:1281...
    Setting to configuration 1
    Setting to interface 0:0
    opening device 05ac:1281...
    Setting to configuration 1
    Setting to interface 0:0
    opening device 05ac:1281...
    Setting to configuration 1
    Setting to interface 0:0

    It does this over and over in terminal and doesn't stop. The instructions say that text should scroll on my phone screen. That doesn't happen. I can't get my phone out of recovery. Is the recovery fix supposed to run in terminal or open as an os x app?
     
  2. drummr macrumors regular

    Joined:
    Feb 17, 2011
  3. Djlild7hina macrumors 6502a

    Joined:
    Mar 28, 2009
    #3
    i had this problem too... when i tried restoring with tinyumbrella. what i did was put the phone in dfu mode first and then reran the kick out of recovery mode file.
     
  4. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #4
    Was your Iphone SHSH blob saved previously?
     
  5. whiskey macrumors member

    Joined:
    Aug 23, 2006
    #5
    I don't mean to go side track, but is there a reason why you wouldn't use pwnagetool 4.3 instead? isn't it easier this way? I'm not too familiar with jailbreaking so maybe I'm missing something?
     
  6. Coleman2010, Apr 7, 2011
    Last edited: Apr 7, 2011

    Coleman2010 thread starter macrumors 68000

    Joined:
    Oct 9, 2010
    Location:
    NYC
    #6
    I think I have it in DFU mode and I reran the recovery fix. It ran in terminal and I got the following in terminal. Again, I did not see any thing run on the iPhone screen.


    Last login: Thu Apr 7 09:06:20 on ttys000
    t02aul00179:~ 09060529$ /Users/09060529/Downloads/fixrecovery-osx/fixrecovery43 ; exit;
    Initializing libpois0n
    No matching processes belonging to you were found
    Waiting for device to enter DFU mode
    opening device 05ac:1227...
    Found device in DFU mode
    Checking if device is compatible with this jailbreak
    Checking the device type
    Identified device as iPhone3,1
    Preparing to upload limera1n exploit
    Resetting device counters
    Sending chunk headers
    Sending exploit payload
    Sending fake data
    libusb:error [darwin_transfer_status] transfer error: timed out
    Exploit sent
    Reconnecting to device
    libusb:error [darwin_close] USBDeviceClose: no connection to an IOService
    Waiting 2 seconds for the device to pop up...
    opening device 05ac:1227...
    Preparing to upload iBSS
    Checking if iBSS.n90ap already exists
    Preparing to fetch DFU image from Apple's servers
    Fetching Firmware/dfu/iBSS.n90ap.RELEASE.dfu...
    Segmentation fault: 11
    logout

    [Process completed]

    Terminal stops but the phone stays on the black screen and nothing appears on screen. Is this what it's supposed to do?
     
  7. Coleman2010 thread starter macrumors 68000

    Joined:
    Oct 9, 2010
    Location:
    NYC
    #7
    Yes. I have them saved.
     
  8. Coleman2010 thread starter macrumors 68000

    Joined:
    Oct 9, 2010
    Location:
    NYC
    #8
    I got the recovery fix to work. It looks like the firewall at work was blocking the recovery fix from reaching the apple server in terminal. So I tried connected my Mac over a sprint MiFi and ran it. That worked.
     

Share This Page