update to new iPT, killed it error 1604

Discussion in 'iPod touch' started by 1458279, Mar 18, 2011.

  1. 1458279 Suspended

    1458279

    Joined:
    May 1, 2010
    Location:
    California
    #1
    I downloaded a new game for the iPT, iTunes said there was an update for my iPT, do I downloaded that as well. After an hour of downloading, it started to install and gave the error 1604.
    I researched it and it said to try other usb ports, I did and same thing.

    After trying different usb ports and rebooting the computer, same results.

    I'm not using a dock, std Apple usb cable.

    I've updated this iPT with this computer before and had no problems, the iPT is about 6 weeks old now.

    I did however get a new computer, I noticed that when iTunes came up on this new computer (old HD, same install of XP with a new MB/Vid/CPU...) It asked me if I wanted to have this computer registered for use with my iTunes account, I said yes and have been using it and updating my iPT several times over the past few weeks.

    I thought it might be something with changing the computer, so I tired to install iTunes on my notebook and it came up with error Assembly microsoft VC80.CRT...
    So I'm upgrading Vista on that computer to see if iTunes will install there.

    I'd like to get the iPT working, anyone know what the 1604 error is? Is the update for iPT something that everyone was getting and did others fail?
    Any suggestions?
    thanks, KarlJay.
     
  2. xlii macrumors 68000

    xlii

    Joined:
    Sep 19, 2006
    Location:
    Millis, Massachusetts
    #2
    Error 1604: This error is often related to USB timing. Try changing USB ports, uninstalling and reinstalling USB ports, and other available USB troubleshooting steps (troubleshooting USB connections, device not recognized properly, computer won't recognize a FireWire or USB device). If you are using a dock, bypass it and connect directly to the USB 30-pin dock-connector cable. If the issue persists on a known-good computer, the device may need service.

    If the issue is not resolved by USB isolation troubleshooting, and another computer is not available, try these steps to resolve the issue:

    Connect the device to iTunes, confirm that the device is in Recovery Mode. If it's not in Recovery Mode, put it into Recovery Mode.
    Restore and wait for error 1604.
    When prompted, click OK.
    Close and re-open iTunes while iPhone remains connected.
    iPhone should now be recognized in Recovery Mode again.
    Try to restore again.
    If the steps above do not resolve the issue, try restoring using a known-good USB cable, computer, and network connection.

    If you google "1604 error iphone 4" you should come up with plenty of tutorials to try and fix your problem.
     
  3. 1458279 thread starter Suspended

    1458279

    Joined:
    May 1, 2010
    Location:
    California
    #3
    Solved: updated iTunes, XP saw new usb devices twice, rebooted twice and it finally updated.

    Hope these 'updates' aren't very often. Ends up it was probably a USB driver issue and updates in iTunes.

    By the way... the google came back with re-download videos, tell you to re-download the updates, this didn't work, several other ideas were thrown around none of which worked.
     

Share This Page