Updated, and now sound/volume issues

NativeTxn

macrumors regular
Original poster
Feb 11, 2013
132
8
I updated my late 2013 15" rMBP to Yosemite last night, and it appeared that everything was working well.

However, this morning when I started the computer and began working on it while it was attached via HMDI cables to my dual monitor setup, I noticed that the sound was not working properly.

Sound is/was not an issue when I was just using the laptop by itself last night. But today, the volume icon in the menu bar is grayed out and when you click on it, it shows that it is at full volume. When I use the fn + volume up button on my wireless Apple keyboard, it brings up the icon that used to come up, but in stead of adjusting the volume it just shows a circle with a line through it under the speaker picture (it will not adjust up or down).

When I go into settings-sound, it will not let me adjust the actual volume there either.

I unplugged both monitors and the sounds worked again just fine, with the ability to adjust it either with the fn+up/down feature, or using the volume iconic the menu bar.

When I was on Mavericks, I never had any issues with adjusting the volume while using the dual monitor setup.

So, I don't know if this is a Yosemite bug, or if the update default a setting(s) that I don't know about, or if it is something else all together.

Anyone run across a similar situation?

Any thoughts/suggestions?

Any help is appreciated!

[Update: I just restarted the computer while it was attached to the dual monitors. During the restart process, it made the "startup chime" sound as it always has, but I am still having the above issues with the volume after reset.]
 

Martyimac

macrumors 68000
Aug 19, 2009
1,854
1,174
S. AZ.
Don't know if this will help but I had to go in to the settings and re designate my desktop speakers as the default output and now sound is working okay. I had the same problem you did before I did this.
 

NativeTxn

macrumors regular
Original poster
Feb 11, 2013
132
8
Don't know if this will help but I had to go in to the settings and re designate my desktop speakers as the default output and now sound is working okay. I had the same problem you did before I did this.
Yep - that worked. Thanks!
 

geoff5093

macrumors 68020
Sep 16, 2014
2,221
2,512
Dover, NH
I was stumped by this for a while today as well after migrating. Going to the sound output settings in system preferences and switching it to the internal speakers fixed it.
 

menano

macrumors regular
Jun 7, 2011
127
37
Neverland
Ia m also having a small volume issue on my newMacPro - if I plug my speakers I can't control the volume through the keyboard. With the internal or display speakers it works fine, but with my speakers I get this icon (attachment)

Any ideas on how to fix this?
 

Attachments