Updated apps won't transfer to phone -- error on sync

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rogersmj, Sep 5, 2008.

  1. rogersmj macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #1
    For a few weeks now, every time I update apps in iTunes I have a problem syncing the phone (1st gen on 2.0.2). At the end of the sync, an error box will pop up saying

    "Some of the applications in your iTunes library were not installed on the iPhone "iPhone" because one or more errors occurred."

    Then there's a list of all the apps that were just updated, and each line says that app wasn't installed because an unknown error occurred (0xE800002E).

    I've searched around for this and haven't been able to find a fix. The workaround is to remove those apps from the phone first, then resync -- but that's time consuming and annoying. Any ideas?
     
  2. gray67 macrumors member

    gray67

    Joined:
    Aug 6, 2008
    #2
    This is happening to me as well. There are threads on the forum that seem to indicate this is a fairly common problem. I'm hoping that Apple's Sept. OS update will resolve the issue. The only known solution is to do what you are doing. SOmeone suggested plugging the USB cable directly into the bus rather than using a hub, which I've tried, and to only use the original cable, which I haven't tried.

    So far I've been lucky in that the apps that are being updated are not ones that store data on the iPhone itself. I'm kind of worried that one of my paid apps will be updated and I'll run into this error, make the manual fix, and lose all my stored data. In which case I will be severely pissed.
     
  3. moebiuscreative macrumors newbie

    Joined:
    Oct 10, 2008
    #3
    After trying everything [deauthorize, delete app, re-download app, restart, reset, restore — all x 2] this is what finally worked for me. Thanks very much for posting it.
     
  4. redbill macrumors newbie

    Joined:
    Jul 31, 2008
    #4
    I'm having this problem now with 19 of my applications, I can't update anything anymore. I doubt resetting and restoring will work, and I'm tired of having to do that. And I don't feel like I should have to delete all my apps and lose all my data and settings. Any other suggestions? Or just stick with my old apps and hope it gets fixed with an update?
     
  5. eight08 macrumors newbie

    Joined:
    Oct 16, 2008
    #5
    I've been having the same issue with my 3G w/ 2.1 FW. When trying to sync my Texas Hold 'Em app it gets stuck and sits there....:mad:
     
  6. kowen3 macrumors newbie

    Joined:
    Nov 1, 2008
    #6
    Can't synch apps from iTunes to iPhone 3G

    Lost all my apps on my iPhone when Apple support told me to 'restore' my phone. I now can't get them back to my phone. They appear in iTunes but when I sync there is an error that says:

    'The application "app name" was not installed on the iPhone because an unknown error occurred (0xE 800002E)'

    I tried to re-download the app directly to my iPhone, but the App Store says I must do it through iTunes since I have already downloaded it.

    I have tried all the tips and tricks I can find and nothing has worked. I even re-installed iTunes and that didn't work.

    ANY SUGGESTIONS???? THANKS!!!!
     
  7. designer.eb macrumors newbie

    Joined:
    Apr 6, 2009
    #7
    Here's what worked for me after Apple had me restore my phone...

    I had everything backed up (including my apps) but I was receiving the same error as above when I tried putting my apps back onto my phone.

    I had to go into iTunes>Applications and double-click on one of the offending applications. It asked me to authorize it for that specific computer by entering my password. After entering my iTunes password, it authorized all the apps.

    Not sure why I was able to back them up when they supposedly weren't authorized but whatever.

    Hope that helps.
     

Share This Page