Updated CUDA driver now my CUDA won't work!

Discussion in 'Mac Pro' started by pixelatednoise, Apr 2, 2015.

  1. pixelatednoise macrumors newbie

    Joined:
    Apr 1, 2015
    #1
    Hey guys I am running 2 GTX 780 Ti's in my mac pro. I had everything working but now that I have updated the Nvidia drivers my CUDA isn't being recognized in the software I use. Anyone know how to fix and which previous drivers I need?
     
  2. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #2
  3. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #3
  4. pixelatednoise thread starter macrumors newbie

    Joined:
    Apr 1, 2015
    #4
    Thanks
    I have the latest drivers and CUDA installed. Its really weird I am currently trying to trouble shoot this.

    If I start up with one of my 780 ti's I don't get a screen image my monitors are blank.

    If I start up with one of my 780 ti's in one slot and my ATI 5870 in another It will load and recognize the card (but only as Nividia Chip Model and without CUDA)

    Before I installed the update everything was working fine. I had both 780 tis up and running with CUDA recognized and I was good to go. As soon as I updated all hell broke loose.
     
  5. pixelatednoise thread starter macrumors newbie

    Joined:
    Apr 1, 2015
    #5
    Seems I am in deep.

    Nothing works now. I have tried installing the latest drivers and my card is now just read as a generic pci10de,e1a or a "Nvidia Chip Model". Im thinking this was a huge mistake trying to install 2 x 780 tis in this machine. I may just get the Quadro k5000 for mac and call it a day but its so expensive but this is such a headache to try and get working. Someone PLEASE HELP!!!
     
  6. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #6
    Have a cup of tea and relax.

    Very little will get figured out if you are frantic.

    780ti has unfortunately been left in the "never heard of it" OSX driver land.

    I can only assume that Apple doesn't like their $10K whirling dervish being outpaced by cMP and have thus pledged to NEVER update OSX NVIDIA drivers.

    It is an embarassment that they have basically not updated them since 10.8.5. Completely unprofessional just to try to keep their nMP mildly relevant by kneecapping the older one.

    Anyhow, there is no version of OSX with drivers for 780Ti. So the Web Driver is a necessity. Despite being a couple years old now, that GK110 chip is just as "so new it's not in the OS" just like a 2 week old Titan-X.

    So, you must install web driver with another card in AND make sure it is running BEFORE putting in 780Ti. The GTX780 regular and original Titan are last "new" NVIDIA cards with OSX support.

    Unflashed 780ti a little more bother since if driver not working, they don't work. If you have to truly buggered it all up, just reinstall the OS, then the Web Drivers. And the 8 pins must be fully powered, external PSU needs paperclip trick etc.

    Also keep in mind that a PRAM reset or NVRAM reset turns the web drivers back off so if you do one, you will need to turn them back on before 780ti will work AT ALL.
     
  7. lewnworxx, Apr 4, 2015
    Last edited: Apr 4, 2015

    lewnworxx macrumors member

    Joined:
    Mar 19, 2015
    #7
    Ok, FWIW, even with both of those installed, my dual 970's run under the web driver, however, Cuda is broken. Neither CUDA-z or blender even see the GPU's Cuda Z reports "No cuda devices found".

    Now this may be specific to me, as I originally installed the the first video card (a flashed GTX 680 4 GB) on the very day the 3rd security patch came out, so I updated from 10.9.x to 10.10.2 on that day, and before I could change the settings during the install OS X went out and got the security patch and installed it as part of the OS install (taking me to 14C1514), so I had to unpackage the NVIDIA installer, bypass the hardware and software checks so it would install, and manually fix the build number so the driver would run.

    Now I could have done a complete reinstall of 10.10.0 at that point when 343.02.02F04 came out to fix all this as that one would run on 14C1514 which is what I'd have ended up with at that point, and in fact I did try that, but used migration assistant when I did, and whatever I'd broke under the hood getting 343.02.02F03 came along for the ride. I had to use migration assistant as I really wasn't looking forward to reinstalling Logic Pro from scratch (all 14 DVD's of it), Aperture (and all my various custom metadata presets and workflow related stuff) and my work VPN and email stuff etc.

    So after migration assistant did it's thing the 343.02.02F04 drivers would not work, so I edited the system.version.plist back to the build prior to 14C1514 in order to the the 343.02.02F03 drivers to install, then reedited the system.version.plist back to 14C1514 so the Nvidia pref pane would reinstall 343.02.02F04. That actually worked and is where I was until 346.01.01f01 came out.

    At any rate, the combination of 346.01.01f01 and cudadriver 7.0.35 is NOT working on my box, and I'm somewhat fearful I'll have to wipe the entire boot volume and start over from scratch at some point to get the drivers to play nice, as something went awry during that process.

    I sure wish to hell Apple would turn off the "we know more about what you want to do with your box than you do" during a fresh install and NOT just go out and grab and install updates whether you want them to or not.

    While you can disable the auto install of software updates AFTER you've done an install, there's no way I know of of preventing it from doing so DURING a fresh install from scratch.

    The super annoying thing about all this? For years one of the main reasons I've been a mac guy is I didn't have to jack around with this sort of crap. I always took a certain pride in not having to go through all this tweaky crap the windows people had to deal with. And now, I'm having to do exactly that just to get the damn box to do what I need it to do.

    At any rate, at least I'm able to render.. For now.
     
  8. pixelatednoise thread starter macrumors newbie

    Joined:
    Apr 1, 2015
    #8
    Thanks MacVidCards

    I managed to get a good night sleep and the next morning did a fresh reinstall of the OS. Downloaded the latest Nvidia web drivers and installed the latest CUDA from the 4/2 updates. Everything is working fine and turns out I think I found the problem.

    As I was working on the system I wouldn't screw the cards in I would just place them in as it fit snuggly and then connect the power and monitor DVI. I have a strong suspicion that I just knocked the card out of place or had the power cord not sit properly and was the cause of all my problems. (happened once after the fresh install of everything) Once I locked every thing down and tightened all the connections I haven't had any issues. Lets just hope all this panic and frustration was due to something as simple and stupid as a loose connection from mucking around in the guts too long.

    Thanks for the help though. Greatly appreciated.
     
  9. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #9

    That's a whole lot of Rosie! Sorry for your trial and tribulations :-/

    My routine (thewebb) is to download the OSX installer e.g 10.9.0 and copy that maiden voyage to my NAS. All upcoming updates I do with the combo installers from 10.9.2 and forth. So on my NAS I now keep all original 10.x installers and their combo updates in seperate folders.

    If you just let them sit in your applications folder Apple will get hold of it and update them to the latest version.

    Having all native OSX 10.x.0 installers copied to my NAS I can always revert to a version of my needs and likings, without the BS that some updates causes.

    Just my € 0,02 for managing YOUR OWNED cMacPro with all added non-Apple goodies in it!

    Cheers and glad you are up-and- running again!
     

Share This Page